1.
Program u666;
Var
x, y, z, t, n, e, z1, z2, z3: real;
Begin
readln (e, x, y);
if sqrt (3*y)+x = 14
then
begin
z1:= Exp(3*x*y);
z2:= x+3*y;
z3:= 0.5*x;
writeln (z1);
writeln (z2);
writeln (z3)
end
else
z:= 0;
writeln (z);
end.
2. Program Regret;
var x: integer;
begin
read (x);
if (x=1) or (x=3) or (x=5) or (x=7) or (x=8) or (x=10) or (x=12)
then write ('31');
if (x=4) or (x=6) or (x=9) or (x=11)
then write ('30');
if (x=2)
then write ('28')
end.
Объяснение:
Интернет урок)
Поделитесь своими знаниями, ответьте на вопрос:
Составьте программу в паскаль, вводящую true, если высказывание является истинным, и false в противном случае. а) сумма цифр трёхзначного числа х является чётным числом.
var a,b,c,x: integer;
begin
readln(x);
a := x div 100;
b := x div 10 mod 10;
c := x mod 10;
if ((a+b+c) mod 2=0) then writeln('true')
else writeln('false');
end.