bk4552018345
?>

Напишите программу, которая выводит все простые числа софи жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от k до n ( 2 ≤ k ≤ n ≤ 100000 входные данные входная строка содержит два натуральных числа, разделённые пробелом, k и n ( 2 ≤ k ≤ n ≤ 100000 ). выходные данные программа должна вывести все простые числа софи жермен в диапазоне от k до n в одну строку, разделив их пробелами. если таких чисел нет, нужно вывести число 0. примеры входные данные 100 200 выходные данные 113 131 173 179 191 входные данные 200 220 выходные данные 0 паскаль abc 1.8

Информатика

Ответы

Reutskii-Kirilovskii1625
 function simpl(n: integer): boolean;
var i,k: integer;
begin
   i:=2;
   k:=round(sqrt(n));
   while ((n mod i)<>0) and (i<=k) do   
   i:=i+1; 
   simpl:=(i>k)
end;
{ основная программа }
var i,k,n,m: integer;
begin
  readln(k,n);
  m:=0;
  for i:=k to n do
  if simpl(i) and simpl(i*2+1) then
  begin
    write(i,' ');
    m:=1;
  end;
  if m=0 then writeln(0);
end.

10 100
11 23 29 41 53 83 89

12 20
0
Milovidova
Первый компьютер и был, и не был. Не был потому, что его автор Чарльз Бэббиджне смог его построить: в то время (он начал свою работу в 1834 году) подобная машина могла быть только механической. Но точность изготовлении деталей была слишком высока по их меркам. Поэтому финансирование проекта прекратилась. Но все же первый компьютер был - не осуществленный, но продуманный до мелочей и тщательно вычерченный. Кроме чертежей, осталась еще и подробное словесное описание, составленной сотрудницей Бэббиджа Августой Адой Лавлейс, разработанная ею язык программирования и несколько первых в истории программ (перфокарты, машина Бэббиджа была выполнять программы). Его основные части были теми же, что и в каждом современном компьютере: устройства ввода данных (клавиатура); запоминающее устройство хранить исходные данные; арифметическое устройство (-,+,·,:); устройство для вывода результата.
Zeegofer
А)1000010100  складываем по 1 биту по правилу 1+0=1,1+1=10,0+0=0 Если 
 +                   получается 10,то берем единицу и прибавляем к биту 
   1101010101  находящемуся левее
 10101101001
Г) 1430,2 здесь складываем как в десятичной, но если получается больше 7, то,
+             если это 8,то переносим 1 в разряд левее, в другом случае из числа 
     666,3  
        2316,5 вычитаем 8 переносим 1 и оставляем в этом разряде, то что осталось от вычитания
 Д)  388,3   
     +             
 209,4
      591,7
Тут тоже, что с восьмеричной только, если получилось 16, то переносим 1 , а если больше, то вычитаем

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая выводит все простые числа софи жермен (такие, что для числа p число 2 p + 1 тоже простое) в диапазоне от k до n ( 2 ≤ k ≤ n ≤ 100000 входные данные входная строка содержит два натуральных числа, разделённые пробелом, k и n ( 2 ≤ k ≤ n ≤ 100000 ). выходные данные программа должна вывести все простые числа софи жермен в диапазоне от k до n в одну строку, разделив их пробелами. если таких чисел нет, нужно вывести число 0. примеры входные данные 100 200 выходные данные 113 131 173 179 191 входные данные 200 220 выходные данные 0 паскаль abc 1.8
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vahmistrova
YuREVICh646
iuv61
Вадимовна
Vladimirovna Viktorovna
cimora-kativ
verynzik66525
BogdanR106203
dimalihachew
mstrshulz
kreon1
cherkashenko87543
Александр734
dima0218687
Дмитрий_Владимирович1162