Andrei Morozov
?>

Паскаль: 1. составить программу вычисляющую площадь кольца, заключенного между радиусами r1 и r2

Информатика

Ответы

Aliferenko
Const Pi=3.14;
var r1,r2:real;
begin
write('Введите внешний радиус кольца: ');
readln(r1);
write('Введите внутренний радиус кольца: ');
readln(r2);
writeln('S=',Pi*(r1*r1-r2*r2):6);
end.
писал по формуле S=пи*(R-r)
zeltos384

Объяснение:

Задание 1

program bukva;

const R=[' ','.',',',';',':','?','!','-']; // разделители

var

s,bukv:string;

i,kol,len:integer;

procedure UpCaseRus(var s:string);

{русские в верхний регистр}

var i:integer;

begin

for i:=1 to length(s) do

if s[i] in ['а'..'п'] then s[i]:=chr(ord(s[i])-32)

else if s[i] in ['р'..'я'] then s[i]:=chr(ord(s[i])-80)

else if s[i]='ё' then s[i]:='Ё';

end;

begin

readln(s);

readln(bukv);

UpCaseRus(s);

UpCaseRus(bukv);

For i:=length(s) downto 2 do

if ((s[i] in R) and (s[i-1] in R)) then delete(s,i,1);

len:=length(s);

kol:=0;

for i:=len downto 1 do

begin

if s[i] in R then

if s[i+1]=bukv then kol:=kol+1;

end;

if s[1]=bukv then kol:=kol+1;

writeln('Слов на букву '+bukv+' ',kol);

readln;

end.

Задание 2

const r=[' ','.',',',';',':','?','!','-'];

var

s:string;

i,kol,d:integer;

begin

readln(s);

len:=length(s);

kol:=0;  d:=0;

For i:=length(s) downto 2 do

       if ((s[i] in r) and (s[i-1] in r)) then delete(s,i,1);

for i:=1 to length(s) do

begin

if s[i] in r then kol:=kol+1

else if (s[i] in ['0'..'9']) then d:=d+1;

end;

writeln('Слов всего ',kol+1);

writeln('Цифр  в тексте ',d);

readln;

end.


Информатика. , кто разбирается) чепуху не писать, для уточнений есть комментарии. протестировать про
ynikolaev2657
В каталоге уровень "вверх" означает движение к корневому каталогу, "вниз - от корневого. Обозначим движение "вверх" через уровень+1, "вниз" - через уровень-1. Получаем смещение относительно исходного уровня, равное +1-1-1-1=-2.
Если в результате пользователь оказался в каталоге C:\учеба\информатика \ ГИА, то изначально он должен был находиться на два уровня выше, т.е. в каталоге C:\учеба
К сожалению, такого варианта в ответах нет, следовательно, либо неверно условие, либо ошибка в вариантах ответов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль: 1. составить программу вычисляющую площадь кольца, заключенного между радиусами r1 и r2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sirenashop25
Елена-Семенова
vickuznetsova8677
alislisa191
anton
arbat
martabunova
rgmarket
Elenazhukovafashion7
Vyacheslavovna1867
galkar
farmprofi
amramzi
es196
fruktovahere