Курнев-Анастасия359
?>

)написать программу вычисления стоимости покупки, вводя по очереди с клавиатуры цену и количество 10 товаров. заранее

Информатика

Ответы

Геннадьевна Вета560
Program znanija;
var 
res:integer;
n, i, a:integer;
begin

write('Введите кол-во товаров: ');
readln(n);

write('Введите цены: ');
for i := 1 to n do
begin 
read(a); 
res := res + a;
end;

write('Стоимость покупки = ');
writeln(res);
end.
kolesnikovaen
1) набрать 5 л и перелить в 9-литровое ведро.
2) набрать еще 5 л и перелить 4 л доверху в 9-литровое ведро. В 5-литровом ведре останется 1л.
3) опустошить 9-литровое ведро т перелить в него 1 л из 5-литрового.
4) набрать 5л и перелить в 9-литровое, где уже есть 1 л, после чего в 9-литровом окажется 6 л.
5) набрать еще 5 л и переливать в 9-литровое 3л, пока 9-литровое не заполнится. В 5-литровом останется 2 л.
6) опустошить 9-литровое и перелить из 5-литрового 2 л в 9-литровое.
7) набрать 5 л и перелить в 9-литровое к имеющимся в нем 2 л воды. В 9-литровом окажется 7 л.
8) набрать 5 л и переливать в 9-литровое 2 л, пока оно не заполнится. В 5-литровом останется 3л.
9) вылить всю воду из 9-литрового и нести домой 3д в 5- литровом ведре и пустое 9-литровое ведро.
manimen345
1.  Правильно ли определён тип величины?
а) количество тетрадей - вещественный тип
Конечно, количество тетерадей - это целое число. Но если вспомнить, что целые числа являются подмножеством вещественных, то вполне допустимо использовать и вещественный тип. Так что по-школьному тип должен быть целым, а в реальности программирования все определяется условиями конкретной задачи.
б) кличка собаки - символьный тип
Это правильно.
в) вес контейнера - целый тип
См. a). В частном случае веса контейнеров могут быть целыми. В более общем, если известно, что веса могут быть нецелыми, назначается вещественный тип.
2) Укажите тип величины, если значение равно:
а) ‘компьютер’
символьный тип
б) 115
целый тип
в) 0.15
вещественный тип
3) Из приведённых значений выберите допустимые для величин
а) целого типа (BYTE)
30; -46
б) вещественного типа
-0.126; 15.003;
в) литерного (символьного) типа
‘g’
г) строкового типа
‘солнце’
д) целого типа (INTEGER)
30; -46;
4) Определите является ли величина постоянной или переменной:
а) количество дней в неделе
постоянная величина, равная 7
б) название естественного спутника Земли
Зависит от применения. Название - величина символьного типа. Если это календарь лунных затмений. то название "Луна" - постоянная величина. А если это программа перевода, то на каждом языке "Луна" пишется по-своему и это уже переменная величина.
в) количество дней в январе месяце
В январе 31 день и это постоянная величина
г) количество дней в месяце
Это переменная величина, потому что количество дней в разных месяцах может отличаться.
5) Определите тип для величин:
а) скорость машины
вещественный тип, если скорость может принимать нецелые значения. А если всегда только целые, то и тип целый.
б) название фильма
символьный тип
в) количество учебных предметов
целый тип
6) Для величины КОЛИЧЕСТВО СТРАНИЦ В КНИГЕ выберите допустимое:
293; ‘сорок’; 123; ‘тридцать пять’
Указание количества строк прописью также возможно, все зависит от области использования этой величины. Если с количеством делаются какие-то арифметические или логические действия (подсчет, сравнение), то тип должен быть целым. А если количество только выводится, оно может быть и символьным.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

)написать программу вычисления стоимости покупки, вводя по очереди с клавиатуры цену и количество 10 товаров. заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ribanina
Сергеевич1907
diana-kampoteks
ivanjeka87
Olesyamilenina8
masum-2011687
Федоровна-Васильева
oksanashabanovadc3197
Овчинников_Грузман
kirillboytsov403
Salnikov1730
char40
Sazhina1356
inainainainaina0073
Vladimirovich1898