maruska90
?>

Задана матрица f(3, 3 определить, равны ли все элементы первого столбца соответствующим элементам главной диагонали. если нет, то поменять их местами60 ) на с# написать программу

Информатика

Ответы

tatianamatsimoh
Using System;

class Program
{
    static void Main()
    {
        var random = new Random(DateTime.Now.Millisecond);
        int n = 3;
        var f = new int[n, n];
        int c;

        Console.WriteLine("f:");
        for (var i = 0; i < n; i++)
        {
            for (var j = 0; j < n; j++)
            {
                f[i, j] = random.Next(0, 9);
                Console.Write(f[i, j] + " ");
            }
            Console.WriteLine();
        }
        Console.WriteLine();
        for(int i = 0; i < n; i++) {
        if (f[i,0] != f[i,i]){
        c = f[i,0]; f[i,0] = f[i,i]; f[i,i] = c;
        }
        }
        Console.WriteLine("New f:");
        for(int i = 0; i < n; i++){
        for (var j = 0; j < n; j++)
           Console.Write(f[i,j] + " ");
        Console.WriteLine();
        }
       
        Console.WriteLine();
        Console.ReadKey();
    }
}

Пример:
f:
8 1 0
3 6 3
0 5 7
 
New f:
8 1 0
6 3 3
7 5 0
usmanovayanq2626
Язык Паскаль был создан Никлаусом Виртом в 1968—1969 годах после его участия в работе комитета разработки стандарта языка Алгол-68. Язык назван в честь французского математика, физика, литератора и философа Блеза Паскаля, который создал первую в мире механическую машину, складывающую два числа. Первая публикация Вирта о языке датирована 1970 годом; представляя язык, автор в качестве цели его создания указывал построение небольшого и эффективного языка хорошему стилю программирования, использующему структурное программирование и структурированные данные.

Последующая работа Вирта была направлена на создание на основе Паскаля языка системного программирования, с сохранением возможности вести на его базе систематический, целостный курс обучения профессиональному программированию.Результат этой работы — язык Модула-2.
Елена-Семенова
Язык Паскаль был создан Никлаусом Виртом в 1968—1969 годах после его участия в работе комитета разработки стандарта языка Алгол-68. Язык назван в честь французского математика, физика, литератора и философа Блеза Паскаля, который создал первую в мире механическую машину, складывающую два числа. Первая публикация Вирта о языке датирована 1970 годом; представляя язык, автор в качестве цели его создания указывал построение небольшого и эффективного языка хорошему стилю программирования, использующему структурное программирование и структурированные данные.

Последующая работа Вирта была направлена на создание на основе Паскаля языка системного программирования, с сохранением возможности вести на его базе систематический, целостный курс обучения профессиональному программированию.Результат этой работы — язык Модула-2.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задана матрица f(3, 3 определить, равны ли все элементы первого столбца соответствующим элементам главной диагонали. если нет, то поменять их местами60 ) на с# написать программу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Беспалова
membuksdk
many858
Овсянкина407
Yurevna-Anatolevna
nofate1016585
ruslanriad10
Shishkinna2002
Ofelya1308
M10M11M12
Rik200081490
dmitrievanata83538
Tkachenko1050
Yurevich-Vladimirovich
optima3559