s45983765471717
?>

Решить в pascal abc написать программу, которая вычисляет факториал числа, введенного с клавиатуры. (факториал числа n называется произведение целых чисел от 1 до n. например, факториал числа 1 равен 1, а числа 8 – 40320.) вычисление факториала. введите число, факториал которого надо вычислить -> 7 факториал 7 равен 5040.

Информатика

Ответы

faberlic0168
Var
N:integer;
F:BigInteger:=1;
Begin
Write('N = ');Read(N);
For N:= 1 to N do
    F:=F*N;
Write(N,'! = ',F)
End.
Sinelnikov1650

будем считать, что каждое четное однозначное число это определенный алфавит, мощность которого обозначается буквой N

N=2^i, подставим вместо N 2, получаем 2=2^i запишем левую часть как степень числа 2: 2^1=2^i, отсюда i=1 бит

подставим теперь вместо N 4, получаем 4=2^i запишем левую часть как степень числа 2: 2^2=2^i, отсюда i=2 бит

подставим теперь вместо N 6, получаем 6=2^i число 6 не является точной степенью числа 2, поэтому ответ найдем по таблице неточных степеней числа 2-  i=2,58 бит

подставим теперь вместо N 8, получаем 8=2^i запишем левую часть как степень числа 2: 2^3=2^i, отсюда i=3 бит


задача2

запишем условие: мощность компьютерного алфавита равна N=256

I=120 бит, К-?

решение: найдем вес одного символа 256=2^i, i=8 бит

разделим I на i и получим кол-во символов в тексте 120/8=15




o-pavlova-8635

Цель урока:

Познакомить учащихся с режимом ввода-редактирования текста, обучить основным приемам работы с текстовым редактором.

Задачи урока:

Образовательная: Образовательная: научить вводить и редактировать текст, научить автоматической проверке правописания, поиск и замена фрагмента текста.

Развивающая: Развить познавательные интересы, навыки работы с мышью и клавиатурой, самоконтроль.

Воспитательная: Воспитание информационной культуры учащихся, внимательности, аккуратности, дисциплинированности, усидчивости.

Ход урока.

I. Орг момент.

Здравствуйте ребята, садитесь.

Меня зовут Елена Геннадьевна. Я буду вести у вас уроки информатики.

Откройте тетради, запишите число и тему урока: «Ввод и редактирование документа».

Сегодня на уроке, мы узнаем, как редактируется документ.

II. Актуализация знаний.

Но сначала несколько вопросов по предыдущим темам.

Что такое текстовый редактор?

Ввод и редактирование документа (конспект)

Что можно назвать стандартными компонентами среды ТР?

Порядок создания документа?

Какие параметры страниц необходимо задать перед началом создания документа?

Какие ориентации страниц существуют?

Что определяет формат страниц документа?

Что определяют размеры полей?

III. Новый материал.

Профессионалы, знакомые с Word давно, умеют выполнять работу с минимальным количеством манипуляций. Их действия не просто умелые, а эффективные, особенно при выполнении повторяющихся задач. Овладев этими вы сможете ускорить свою подготовку документов.

На уроке вы создавали документ в текстовом редакторе, а сегодня мы научимся вводить и редактировать док-т.

Вспомним, что называется документом?

Ввод текста

Ввод-редактирование – это основной режим работы текстового редактора.

Основой большинства документов явл-ся текст.

Что такое текст в информатике?

Существуют правила ввода текста (распечатано на листах).

При работе с текстовым редактором в режиме ввода-редактирования по экрану дисплея перемещается курсор, который указывает текущую позицию для ввода. Символ, соответствующий нажатой клавише, помещается в позицию курсора, который после этого перемещается на один шаг вправо или, если достигнут конец строки, в начало следующей строки.

Весь материал - в документе.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить в pascal abc написать программу, которая вычисляет факториал числа, введенного с клавиатуры. (факториал числа n называется произведение целых чисел от 1 до n. например, факториал числа 1 равен 1, а числа 8 – 40320.) вычисление факториала. введите число, факториал которого надо вычислить -> 7 факториал 7 равен 5040.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Aleksei806
kryshtall2276
Serezhkin
ЕВ1873
maroseyka
Valentina
panasenko68
ldfenix87
Овсянкина407
Galina
Ольга1520
sergei-pletenev
monolit-kolomna
Иванович-Васильевна1153
АндреевичОльга641