ответ: 1количество в процессоре является важным фактором, влияющим на его производительность. как было показано ранее, в процессоре 8088 на выполнение одной инструкции требовалось 15 циклов тактовой частоты. а чтобы выполнить одну 16-битную операцию, уходило и вовсе порядка 80 циклов. так был устроен умножитель алу этого процессора. чем больше и чем мощнее умножитель алу, тем больше всего успевает сделать процессор за один свой такт.
многие поддерживают технологию конвейеризации. в рамках конвейерной архитектуры происходит частичное наложение выполняемых инструкций друг на друга. инструкция может требовать на свое выполнение все тех же пяти циклов, но если процессором одновременно обрабатываются пять команд (на разных этапах завершенности), то в среднем на выполнение одной инструкции потребуется один цикл тактовой частоты процессора.
во многих современных процессорах дешифратор команд не один. и каждый из них поддерживает конвейеризацию. это позволяет выполнять более одной инструкции за один такт процессора. для реализации этой технологии требуется невероятное множество . тут есть все ответи
объяснение:
ответ:
static void main(string[] args)
{
int n; double proizvedenie = 1;
console.write("укажите размерность массива: ");
n = convert.toint32(console.;
int[] mas = new int[n];
random rnd = new random();
for (int i = 0; i < n; i++)
{
mas[i] = rnd.next(1, 10);
}
console.writeline("массив: ");
for (int i = 0; i < n; i++)
{
console.write(string.format("{0,3}", ;
}
console.writeline();
if (n > = 200)
{
for (int i = 0; i < 200; i++)
{
proizvedenie = proizvedenie * math.pow(mas[i], 2);
}
console.writeline("произведение квадратов первых 200 чисел = " + proizvedenie);
}
else
{
console.writeline("размерность массива < 200.");
}
console.writeline();
console.readkey();
}
объяснение:
как я понял из вопроса - создаётся случайный массив из 200+ чисел, и находится произведение квадратов первых 200 чисел. число получается достаточно огромное.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания размер массива заранее неизвестен. исходные данные записаны в файл input.txt , отсортированный массив нужно вывести в файл output.txt . входные данные все элементы массива записаны по одному в каждой строке входного файла input.txt . ввод завершается числом 0. выходные данные программа должна вывести в файл output.txt все элементы отсортированного массива в одной строке, разделив их пробелами. примеры входные данные 5 1 -4 -2 3 0 выходные данные -4 -2 1 3 5
type z = array of integer;
var a: z;
i,n,j,buf,t: integer;
f: text;
begin
assign(f,'input.txt');
reset(f);
n:=1;
t:=0;
while true do
begin
readln(f,t);
if(t<>0) then
begin
setlength(a,n);
a[n-1]:=t;
end else break;
n:=n+1;
end;
close(f);
for i:=0 to n-3 do
for j:=i+1 to n-2 do
if a[i]>a[j] then begin
buf:=a[i];
a[i]:=a[j];
a[j]:=buf;
end;
assign(f,'output.txt');
rewrite(f);
for i:=0 to n-2 do write(f,a[i],' ');
close(f);
end.