ocik1632933
?>

На рисунке изображена блок схеме решения следующей .дана точка на послокости с координатами (х, усоставить программу которая выдаёт одно из сообщений "внутри ", "снаружи ", "на границе"в зависимости от того , лежит ли точка внутри заштрихованной области , или на ее границе. ответы 1..a: (y> -100) и

Информатика

Ответы

r682dm2011
Под заштрихованной областью понимается
y >= -100

var
    x, y: real;
begin
    readln(x, y);
    if y = -100 then writeln('на границе')
    else if y > -100 then writeln('внутри')
    else writeln('снаружи ');
end.
av52nazarov
var
  y: System.uint64; //Большая цЫфра же и положительная
  x, i: byte; //Нет смысла большие числа брать слишком, переполнение будет

begin
  readln(x); //Принимаем число...
  y := 1;
  i := 1;
  repeat
    y *= i; //...и умножаем такое-то количество раз
    i += 1;
  until (i > x);
  if (y = 0) then //Выводим, предусмотрев переполнение
    writeln('Слишком большая цЫферка')
  else
    writeln(y);
end.

Int64 - это то же самое, что LongInt, а Uint64 (unsign long int) - длинное число без знака, при правильном использовании позволяет записывать в переменную числа, в 2 раза превышающие максимум Int64
gre4ka2004
Var
  y: System.uint64; //Большая цЫфра же и положительная
  x, i: byte; //Нет смысла большие числа брать слишком, переполнение будет

begin
  readln(x); //Принимаем число...
  y := 1;
  for i := 1 to x do
    y *= i; //...и умножаем такое-то количество раз
  if (y = 0) then //Выводим, предусмотрев переполнение
    writeln('Слишком большая цЫферка')
  else
    writeln(y);
end.

Int64 - это то же самое, что LongInt, а Uint64 (unsign long int) - длинное число без знака, при правильном использовании позволяет записывать в переменную числа, в 2 раза превышающие максимум Int64

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На рисунке изображена блок схеме решения следующей .дана точка на послокости с координатами (х, усоставить программу которая выдаёт одно из сообщений "внутри ", "снаружи ", "на границе"в зависимости от того , лежит ли точка внутри заштрихованной области , или на ее границе. ответы 1..a: (y> -100) и
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

keldastrand
Хохлов
Наталья_Васищев
Latsukirina
egcuzn86
ВасилийКлимова1695
natura-domA90
Хасанбиевич Колесников716
Abdulganieva1367
Voronin-Albertovich
bellatrixstudio
dmitryshigin
kmalahov
Zebra198383
pastore
▲