guujuu
?>

Информатика! ниже записана программа. получив на вход число x , эта программа печатает два числа, l и m. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7. var x, l, m: integer; begin readln(x); l : = 0; m : = 0; while x > 0 do begin l : = l + 1; if m < x then begin m : = x mod 10; end; x : = x div 10; end; writeln(l); writeln(m); end.

Информатика

Ответы

Yevgenevich1150

Оператор mod возвращает остаток от деления. Четное число – такое, остаток от деления которого на 2 равен нулю.

Функция int возвращает целую часть дробного числа. С её можно реализовать mod (\texttt {a mod b} – примерно то же самое, что и \texttt{a - b * int(a / b)}) или сравнить результат умножения на 2 целой части результата деления исходного числа на 2 с исходным числом.

Код:

begin

   var a := ReadInteger();

   writeln(a mod 2 = 0);

   writeln(a - 2 * int(a / 2) = 0);

   writeln(a = 2 * int(a / 2));

end.


Пример ввода:

5

Пример вывода:

False

False

False


Пример ввода:

42

Пример вывода:

True

True

True

Vitproficosmetics

Напишите рекомендательную систему для нового сервиса Bookflix, подбирающего книги для пользователя. Сервис хранит все прочитанные пользователем книги и по его за Посоветуй мне книгу" должен подобрать набор книг, соответствующий критериям:

книга не должна быть прочитана пользователем ранее.

книга должна быть в любимом жанре пользователя. Любимый жанр – это жанр, который чаще всего встречается в списке прочитанных книг. Любимых

Объяснение:

Напишите рекомендательную систему для нового сервиса Bookflix, подбирающего книги для пользователя. Сервис хранит все прочитанные пользователем книги и по его за Посоветуй мне книгу" должен подобрать набор книг, соответствующий критериям:

книга не должна быть прочитана пользователем ранее.

книга должна быть в любимом жанре пользователя. Любимый жанр – это жанр, который чаще всего встречается в списке прочитанных книг. Любимых

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Информатика! ниже записана программа. получив на вход число x , эта программа печатает два числа, l и m. укажите наибольшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 7. var x, l, m: integer; begin readln(x); l : = 0; m : = 0; while x > 0 do begin l : = l + 1; if m < x then begin m : = x mod 10; end; x : = x div 10; end; writeln(l); writeln(m); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tatyanakras911248
Эдгеева219
madina27821667
ShALIGINA
yaelenatu
v79150101401
Pavlovna-Golovitinskaya378
maroseyka
Курнев-Анастасия359
Некрасова-И
Сергеевич
Nadegdasb
fishka-sokol14
olgabylova6223
gudachaa1480
▲