kononova_Pavel689
?>

Дано 2 целых положительных числа: a и b. требуется написать программу, которая находит цифру, на которую оканчивается число a^b. входные данные результат a=2 b=4 6

Информатика

Ответы

proporcia46
Var A,B,C:integer;
Begin
assign(input,'input.txt');
reset(input);
assgin(output,'outpt');
rewrite(output);
C:=1;
Write('A = ');ReadLn(A);
Write('B = ');ReadLn(B);
For B:= 1 to B do
C:=C*A;
WriteLn(C mod 10);
End.
Марюк-Мубариз
Var A,B,St:integer;
Begin
Write('A = ');
ReadLn(A);
Write('B = ');
ReadLn(B);
St:=1;

For B:= 1 to B do
    St:=St*A;

Write(St mod 10)
End.
cvetyzelen283
Расстояние между ними через Т -  S - v1 * T - v2 * T :
 Допустим 1 стоит, а 2 идет навстречу 1, тогда 2 пройдет расстояние за время Т = скорость на Т (расстояние = скорость умножить на время)
значит сейчас их расстояние будет = Расстояние изначально - Расстояние пройденное = Расстояние Сначала -  скорость умножить на Т;
Теперь пусть будут двигаться они вдвоем,
Значит 1 пройдет расстояние = его Скорость умножить на Т
Тогда расстояние будет = Расстояние изначально - Расстояние, которое Расстояние, которое

подставляем буквы и получаем, что расстояние = 
расстояние изначально - скорость 2 умножить на Т - скорость 1 умножить на Т
rgmarket
с функцией)}
Program n1;
function Dlina(x1,y1,x2,y2: integer):real;
var d: real;
begin
d:= sqrt(sqr(y1-y2)+sqr(x1-x2));
Dlina:=d;
end;
var xa,ya,xb,yb,xc,yc: integer;
ab,bc,ca,S,p: real;
begin
writeln ('введите коорд. вершины A ');
readln (xa,ya);
writeln ('введите коорд. вершины B ');
readln (xb,yb);
writeln ('введите коорд. вершины C ');
readln (xc,yc);
ab:=Dlina(xa,ya,xb,yb);
bc:=Dlina(xb,yb,xc,yc);
ca:=Dlina(xc,yc,xa,ya);
p:=(ab+bc+ca)/2;
S:=sqrt(p*(p-ab)*(p-bc)*(p-ca));
writeln('площадь : ',S);
end.

с процедурой)}
program n2;
var x1,x2,x3,y1,y2,y3,s,a,b,c,p:real;
procedure dlina(q,w,e,r:real; var d:real);
begin
d:=sqrt(sqr(q-w)+sqr(e-r));
end;
begin
writeln ('введите коорд. вершины A ');
readln (x1,y1);
writeln ('введите коорд. вершины B ');
readln (x2,y2);
writeln ('введите коорд. вершины C ');
readln (x3,y3);
dlina(x1,x2,y1,y2,a);
dlina(x2,x3,y2,y3,b);
dlina(x3,x1,y3,y1,c);
p:=(a+b+c)/2;
s:=sqrt(p*(p-a)*(p-b)*(p-c));
writeln('площадь: ',s);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано 2 целых положительных числа: a и b. требуется написать программу, которая находит цифру, на которую оканчивается число a^b. входные данные результат a=2 b=4 6
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

al2nik2ol
martinson
naromanova
ietishkin
ПолухинаТененева565
Мария-Кострыгина175
ivanrancev
Kushchenko-Monashev
Грудинин604
rayon14
Vlad Petr531
Segyn1218
megapolisgroup
Екатерина655
evlampin