pechyclava
?>

45 написать программу, которая из последовательности целых чисел находит сумму всех нечётных чисел кратных 7, кол-во чисел не превышает 500, а по модулю не превыш. 255 0-признак окончания ввода

Информатика

Ответы

vusokaya13
// PascalABC.NET 3.2, сборка 1389 от 01.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
Writeln(ReadSeqIntegerWhile(g->g<>0).Where(x->(x mod 2<>0) and (x mod 7=0)).Sum());
end.
poiskmarina
Сначала код без комментариев:

Var
S:longint;
i:integer;
A:byte;

Begin
S:=0;
Repeat
   Read(A);
   if (A mod 2 <> 0)and(A mod 7 = 0) then S:=S+A;
Until A = 0;
WriteLn('S = ',S);
End.

Теперь объяснение каждой строки:

Var
S:longint;
i:integer;
A:byte; // В эту переменную будет вводится число с клавиатуры. Тип Byte может принимать значения от 0 до 255. Поэтому его как раз хватит.

Begin
S:=0; // Тут будет храниться сумма, поэтому переменную следует сперва обнулить.

Repeat // далее начинается цикл
   Read(A); // эта команда каждый раз считывает с клавы число, и записывает его в переменную A.

   if (A mod 2 <> 0)and(A mod 7 = 0) then S:=S+A; //тут проверяется 2 условия, и если они выполняются - к переменной S прибавляется значение переменной А
   1 условие: число нечётно, то есть остаток от деления его на 2 не равен нулю (A mod 2 <>0)
   2 условие: Число кратно 7, то есть делится без остатка на 7, то есть остаток от деления равен нулю (A mod 7 = 0)

Until A = 0; // Цикл повторяется до тех пор, пока введённое с клавы число не будет равно нулю (A = 0)

WriteLn('S = ',S); // Тут выводится искомая сумма
End.
НиколаевнаОльга
Давай попробуем рассуждать логически.
Если бы сад состоял из двух деревьев, то было бы два варианта садов: 100+99 и 100+101. Если бы досадили третье дерево, то каждый из предыдущих садов удвоил бы число вариантов: первый 100+99+98 и 100+99+100, и так же второй 100+101+100 и 100+101+102. Подмечаем закономерность: каждое добавляемое дерево удваивает количество вариантов. А сад из одного дерева имеет лишь один вариант.

Поэтому ответ: 1 * 2 * 2 * 2 * ... (десять двоек умножаются) = 2^10 = 1024 варианта садов. 

Думаю что так, если не напутал. Но ты лучше проверь за мной. 
ВладимировичСтанислав

2)

Основное содержание темы: Понятие интерактивного Web-документа. Основы интерактивности. Тэг FORM как средство диалога между пользователем и сервером. Основные параметры тэга FORM. Методы пересылки данных на сервере. Элементы управления, используемые при построении формы. Тэги INPUT, SELECT, TEXTAREA. Примеры построения форм для отсылки информации. Общий обзор языка JavaScript. Синтаксис языка JavaScript. Встраивание сценариев в HTML- документы. Web-серверы. Протоколы и сервисы Интернет. Администрирование сайтов: продвижение, обновляемость, обслуживание. Заливка, регистрация и обновление сайта. Варианты встраивания таблиц стилей в HTML документ. Простейшие примеры каскадных таблиц стилей. Применение таблиц стилей. Возможности, которые открывают каскадные таблицы стилей для форматирования HTML-документа.

Подробнее - на -

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

45 написать программу, которая из последовательности целых чисел находит сумму всех нечётных чисел кратных 7, кол-во чисел не превышает 500, а по модулю не превыш. 255 0-признак окончания ввода
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

lyukiss
tatiana2676
Шиловский126
Aleksandr72
mukbidc
Кристина Валентиновна
pak1998378
Никита_Тузов
donertime8
А Дзукаев1562
Екатерина
Наталья_Васищев
Surkova_Pavlovna
alisapavlushina
irina611901