elav20134518
?>

С! заполнить массив из 20 элементов случайными числами найти количество элементов кратных 6.

Информатика

Ответы

belka1976
Program fpro;
var a : array[1..20] of integer;
i : integer;
s : integer;
begin
 s := 0;
 randomize;
 for i :=1 to 20 do
  begin
   a[i] := random(1,100);
   if (a[i] mod 6) = 0 then s := s+1;
 end;
writeln('Количество элементов кратных 6: ', s)
end.
victors

ответ:

объяснение:

если я все правильно понял:

#include "pch.h"

#include

using namespace std;

int main()

{

setlocale(null, "rus");

double a[100];

int n;

cout < < "введи количество элементов массива: "; cin > > n;

cout < < "введи элементы массива: " < < endl;

for (int i = 0; i < n; i++)

  cin > > a[i];

double s = 0;

int fznach, sznach;

for (int i = 0; i < n; i++)

{

  if (a[i] == 0)

  sznach = i;

}

for (int i = n-1; i > = 0; i--)

{

  if (a[i] == 0)

  fznach = i;

}

for (int i = fznach; i < sznach; i++)

  s = s + a[i];

cout < < " искомая сумма равна: " < < s < < endl;

return 0;

}

akopsiroyan
Всем тем, кому не понятен язык, 2. циклы 1. найти наименьший делитель натурального числа 2. найти все делители натурального числа 3. найти наибольший делитель натурального числа 4. найти сумму делителей числа 600 и их количество 5. найти все делители чисел 90 и 360 6. найти натуральное число, произведение всех делителей которого =5832 7. найти натуральное число, если оно делится на 3 и 4 и имеет 14 делителей 8. подсчитать количество делителей натурального числа, сформированное гениратором случайных чисел в диапазоне от 1 др 10000 9. составить проагрмму, которая нашла бы в интервале от 1 до 1000 число, с наибольшим количеством делителей 10. найти натуральное число в пределах о 1 до 10000 с максимальной суммой делителей 11. составить программу, которая бы напечатала бы все простые числав диапазоне от n до m, а также подсчитать их количество. n и m ввести с клавиатуры 12. между любыми двумя последовательными простыми числами находится заданное число к ? 13. найти и вывести на экран 5 простых чисел, больших заданного к, вводится с клавиатуры. 14. дано простое число р. найти следущее простое число 15. задано некоторое натуральное число р. найти ближайшее к нему простое число. 16. найти все трехзначные числа , кратные 7, сумма цифр которых также кратно 7. если найденное число нечетное , определить , является ли оно простым 17. составить программу поиска трех простых чисел, предшествующих числу м , вводимый с клавиатуры ( м > = 10). 18. составить программу поиска всех цифр - близнецов, принадлежащих заданному диапазону [m , n] . 19. дано простое число. есть ли у него число - близнец ? 20. определить, является числа находящихся по обе стороны от заданного четного числа с , близнецами . 21. является ли заданное натуральное число совершенным ? 22. составить программу поиска всех пар дружественных чисел , меньших 10000 . 23. определить количество разрядов натурального числа n, заданного пользователем . 24. вычислить сумму цифр натурального числа n. 25. записать заданное число n в обратном порядке. 26. составить программу , которая проверяет , является ли число n, вводимое с клавиатуры , палиндромом . 27. найти и напечатать все натуральные числа , которые при возведении в квадрат палиндром . 28. составить программу , которая проверяет , есть ли среди палиндромов в интервале [ 10..1000000 ] простые числа. 29. составить программу , печатающую все нечетные палиндромы в интервале [ 10..1000000 ] . 30. найти и напечатать все натуральные числа в интервале [ 1..2000 ] , равные сумме кубов своих цифр . 31. найти и напечатать все натуральные числа в интервале [ 1..5000 ], равные кубу суммы своих цифр . 32. найти и напечатать все четырехзначные числа , у которых сумма первых двух цифр равна сумме двух последних . 33. в заданном натуральном числе выбросить цифры 3 и 7, оставив неизменным порядок других цифр . 34. проанализировать все числа из диапазона [ 10..1000 ] и напечатать те из них , в записи которых нет цифр 3 и 7 . 35. найти количество шестизначных чисел, у которых все цифры разные. 36. на интервале от n до k выбрать те числа ,которые содержат ровно 3 одинаковые цифры . пример : 6766 , 5444 , 0060 , 0006 . 37. составить программу вычисления цифрового корня натурального числа , введенного с клавиатуры. вычислить и напечатать цифровые корни совершенных чисел, принадлежащих диапазону от х до у, вводящихся с клавиатуры 38. вычислить и напечатать все числа в диапазоне [ 10..9999 ] , кратные своему цифровому корню . 39. вычислить и напечатать все числа в диапазоне [ 100..99999 ], цифровой корень которых: кратный 3 или 5 является простым числом 40. задано 3 натуральных числа. найти нод наибольшего и наименьшего из них. 41. сколько существует натуральных чисел от 20 до 120 , а не взаимно простых с 30 ? 42. сколько существует натуральных чисел, меньших 100 и взаимно простых с числом 36 ? 43. найти все натуральные числа , меньше заданного натурального м и взаимно простые с ним. 44. составить программу сокращения дробей . 45. сравнить две дроби по величине . 46. ​​составить программу сложения ( вычитания ) двух дробей . 47. составить программу умножения ( деления ) двух дробей .

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С! заполнить массив из 20 элементов случайными числами найти количество элементов кратных 6.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Ka-shop2791
miyulcha8077
Vyacheslavovich-Gubanov
Геннадьевна_Петр
kampina1
vbg238
sv-opt0076
Ivan1568
MikhailNechaeva
ekvld708
rynaodal
dimkimka386
tkmandarin8376
innavinogradova1385
dentalfamily