КалюкМарасанов1026
?>

Дано предложение. в нем слова разделены пробелом.верно ли , что число слов в предложении больше трёх.напишите программу в паскале . заранее

Информатика

Ответы

Boldinova-Marianna

var

s:string;

i,count:integer;

begin

count:=0;

readln (s);

for i:=1 to length(s) do

if (s[i]=' ') then count:=count+1;

if (count+1 >=3) then

writeln ('Верно')

else

writeln ('Неверно');

end.

mihailpolehin8
Решение задачи в прикрепленном текстовом файле.
Описание алгоритма:
Полученные строки хранятся в массиве s.
Элементы массива сортируются так называемой "пузырьковой" сортировкой. Для сравнения двух строк используется функция less, возвращающая истину если первая из двух переданных в функцию строк лексикографически меньше.
А дальше дело за малым: просто выводим элементы отсортированного массива без первых трех символов (номера строк).
Единственная проблема, которая может возникнуть: на некоторых компьютерах программа не работает с русским языком. Но это уже технические проблемы. Само же решение верно.
Удачи!
Petrosienko_Larisa,1908

1 - 2, 2 - 3, 3 - 2, 4 - 3, 5 - 1, 6 - 4, 7 - 2, 8 - 3, 9 - 1, 10 - 2

Объяснение:

1. Правила доступа к информации на сервере устанавливает: администратор сервера;

2. Региональная сеть обеспечивает связь пользователей, находящихся в одном городе;

3. Телекоммуникационная технология, базирующаяся на использовании электросетей для высокоскоростного информационного обмена, — это PLC;

4. Какое устройство обеспечивает передачу цифровых компьютерных данных по каналам связи - модем

5. Количество информации, передаваемое в единицу времени называется пропускная канала.

6. Общая схема соединения компьютеров в локальной сети называется топология сети.

7. Какой топологии сети не существует - линейная шина.

8. Из чего состоит IP-адрес? - Из четырех чисел в диапазоне от 0 до 255.

9. Какими бывают домены верхнего уровня? - географические и коммерческие - TCP/IP

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано предложение. в нем слова разделены пробелом.верно ли , что число слов в предложении больше трёх.напишите программу в паскале . заранее
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ЕвгенияСергеевна
ninazholnerova9
dovgash2
Svetlaru70
snezhanaklimenkova
dima-pashkovec
Zakharov Lilit
tata-novik
kot271104
Vasilevich Fokin
Yekaterina
Rakitin
ИвановнаВладимир1832
Ivanovich-A.V
tofilev