kgrechin
?>

Составить программу, определяющую результат гадания на ромашке - "любит - не любит", взяв за исходное данное кол-во лепестков n. pascal

Информатика

Ответы

arbekova
Var
n:integer;
Begin
Write('n = ');ReadLn(n);
if n mod 2 = 0 then WriteLn('Не любит')
else WriteLn('Любит')
End.
baeva-larisa8165
#include <iostream>
#include <conio.h>
#include <time.h>
using namespace std;

void main()
{
 srand(time(NULL));
 setlocale(0, "");
 int arr[17];
 int a, b, chet=0, nechet = 0;
cout << "Введите диапазон ." << endl << "Нижняя граница диапазона: "; cin >> a; cout << "Верхняя граница диапазона: "; cin >> b; cout << endl;
for (int i = 0; i < 17; ++i)
{
  arr[i] = a + rand() % (b-a+1);
  cout <<" "<<arr[i];
}
for (int i = 0; i < 17; ++i)
{
  if (arr[i] % 2 == 0) chet++;
 else nechet++;
} if (chet > nechet)
 cout << " \n Четных больше";
else if (nechet>chet)
 cout << "\n Нечетных больше";
else cout << "\n Одинаковое количество четных и нечетных";
 _getch();
}
Shipoopi8
Для решения этой задачи отбросим лишнее и оставим только данные нам факты:
1.Юре не хватает времени на туризм -> Юра не турист.
2. Врач сказал,что разделает увлечение сестры Юры -> Врач - турист.
3. У двух друзей нет нет букв из их имени ни в профессии, ни в увлечении.

Начнем с Тимура.Буквы из его имени есть во всех профессиях,значит к факту №3 он не относится.

Возьмем Юру. Если учитывать факт №3, то из увлечений ему подходит только бег, а из профессий - физик. Влад же у нас получается ,следуя факту №3 , Юрист, увлечение которого - регби. Тогда Тимур у нас является Врачом, который увлекается туризмом.
Решение верное,так как ни один из фактов не нарушен.

ответ: Влад - Юрист - Регби
            Тимур - Врач - Туризм
            Юра - Физик - Бег

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, определяющую результат гадания на ромашке - "любит - не любит", взяв за исходное данное кол-во лепестков n. pascal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Антон
zolotayaoxana1982
stanefimov
ananyananar
1) ? 2) ? 3) ? 4) ? 5) ? 6) ?
stusha78938
Aleksandr556
allaraygor
barekyan096140
vetviptime
flerbuket332
coffeenik20233
ivanovanata36937365
Viktor1316
ирина Альбертовна
laleonaretouch