nagas
?>

Народ, кто разбирается в pascal abs с этими : 1. написать программу, считающее среднее арифметическое цифр числа. 2. написать программу, считающее сумму цифр кратных "3" числа. 2а. написать программу, находящую минимальную цифру в числе. заранее !

Информатика

Ответы

Filintver
Var
A,S,n:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
S:=0;
n:=0;
While A<>0 do
   Begin
   S:=S+A mod 10;
   n:=n+1;
   A:= A div 10
   End;
WriteLn('Sr = ',S/n);
End.

Var
A,S:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
S:=0;
While A<>0 do
   Begin
   if (A mod 10) mod 3 = 0 then S:=S+A mod 10;
   A:=A div 10
   End;
WriteLn('S = ',S);
End.

Var
A,m:integer;
Begin
WriteLn('Введите целое число');
ReadLn(A);
m:=9;
While A<>0 do
   Begin
   if A mod 10 < m then m:= A mod 10;
   A:=A div 10
   End;
WriteLn('Min = ',m);
End.
dmitrymakarov003

1)

а = 2

b = 27

2)

ответ: нужно ввести число 432

3) Код:

var

 x, a, b, c:integer;

Begin

 write('Введите трехзначное число: ');

 readln(x);

 a:= x div 100;

 b:= x div 10 mod 10;

 c:= x mod 10;

 writeln('Вы ввели число: ', x);

 writeln('Число: ', c, b, a);

END.

Объяснения:

1) a = 187; при b:= (a div 10) + 9 мы а (т.е 187) делим на 10 и прибавляем к результату 9, получаем 27.

а= 2, т.к. мы умножаем 10 на b (27) и отнимаем a (187), получаем 83. Функция mod означает получение остатка от деления на 9, т.е. делим 83 на 9 и получаем остаток, а именно 2.

2) 432 делим на 100, получаем а = 4, делим 432 на 10 и получаем остаток от деления на 10 результата, получаем b = 3, далее получаем остаток от деления на 10 числа 432 и получаем 2.

3) Здесь все довольно просто, мы разбили трехзначное число на части и с оператора вывода writeln, вывели число в обратном порядке, т.е. поменяли местами первую и последнюю цифры.

IrinaSolodukhina1495

1) Что входит в алфавит языка Паскаль?

Этот язык состоит из букв латинского алфавита (прописных – А, В, С, D ... X, Y, Z,  строчных –  а, b, с ... x, у, z), арабских цифр (0, 1, 2, 3,4, 5, 6, 7,8,9) и специальных символов.

2) Структура программы?

Program <название программы>;

 <раздел описаний>

begin

 <оператор 1>;

 <оператор 2>;

 . . . . . . .

 <оператор N>;

end.

3) Как записывается раздел описания переменных?

Блок описания данных состоит из раздела описания констант (const), раздела описания переменных (var)

Пример:

const

s = 5;

var

a, b, c:integer;

4) Оператор вывода/ввода:

Write/Writeln('Текст') - оператор вывода

Read/Readln(переменная) - оператор ввода

5) Стандартные функции Паскаля?

Арифметические функции (например, Abs(x), Sqr(x), Sqrt(x))

Функции преобразования типов (например, round(x) - округление)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Народ, кто разбирается в pascal abs с этими : 1. написать программу, считающее среднее арифметическое цифр числа. 2. написать программу, считающее сумму цифр кратных "3" числа. 2а. написать программу, находящую минимальную цифру в числе. заранее !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dms161964937
svetlanam81
andrew409
petrowich076813
nevori
Alex17841
Борисович409
vasilyevjob6
pk199888
viktorovna_Imamaevich679
asviridova07194
ГазалиеваКозак
Катерина Телюкин925
ietishkin
contact