AlekseiBunina1895
?>

17. напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число: сумму всех однозначных чисел, кратных 3.

Информатика

Ответы

marvindkc
Program n1;
var sum,a: integer;
begin
readln(a);
sum:=0;
while a<>0 do
begin
if(a=3) or (a=6) or (a=9) then sum:=sum+a;
readln(a);
end;
writeln(sum);
end.
Екатерина655

Geneza Zemsty

Wiadomo od dawna, że treść utworu Aleksandra Fredry ma swoje źródło w prawdziwym konflikcie, o którym przypadkowo dowiedział się autor. W 1828 r. Fredro ożenił się z Zofią Skarbkową. W posagu wniosła ona połowę starego zamku w Odrzykoniu. Druga część posiadłości należała do innej rodziny.

Fredro z zainteresowaniem przyglądał się dokumentom związanym z otrzymaną posiadłością. Przypadkowo natknął się na papiery procesowe właścicieli zamku. Dotyczyły one konfliktu niegdysiejszych właścicieli z XVII wieku. Był to Piotr Firlej (który zajmował wtedy zamek dolny) i Jan Skotnicki (zamieszkiwał zamek górny).

Firlej był wojewodą, który uważał się za lepszego i bardziej znaczącego niż Skotnicki. Ich konflikt narastał. Skotnicki doprowadził przy reperowaniu muru granicznego) do wylewania się wody z rynien na zamek Firleja. Ten z kolei napadał na robotników sąsiada naprawiających mur. Problemy sąsiedzkie zakończyły się w sądzie. Mimo wyroku prawdziwy rozejm nastał dopiero po ślubie podopiecznej Skotnickiego – Zofii i syna Firleja – Piotra.

Jak więc widać, Fredro zaczerpnął swój pomysł na treść utworu z autentycznej historii. Także charaktery jego postaci – Cześnika i Rejenta odpowiadają usposobieniu swoich prawdziwych pierwowzorów. Występuje też analogiczna historia z murem i oczywiście finalne pojednanie. Do odnalezionej historii dodał autor popis swojego kunsztu pisarskiego i humoru. I tak powstało dzieło, które od wieków bawi i poucza czytelników oraz widzów – gdy jest wystawiane w teatrze.

Warto też dodać, że Zemsta została napisana w 1833 r. Fredro był już dojrzałym twórcą, znanym szerszej publiczności. Prapremiera utworu odbyła się w 1834 r. we Lwowie. Sama książka wydana została jednak aż cztery lata później, w 1838 r. – w zbiorze dzieł pisarza.

kia80
1. Даны высота треугольника h и площадь S. Вычислить сторону треугольника.

var h,S:integer;
a:real;
begin
writeln(“Input h and S”);
readln(h,S);
a:=S/h*2;
writeln(“a = “,a);
end.
2. На вход программы подается число, отличное от 0. Определить положительное оно или отрицательное.

var a:integer;
begin
writeln(“Input a”);
readln(a);
if a>0
writeln(“Positive”)
else
writeln(“Negative”);
end.
3. На вход программы подается число n. Вывести значения степеней 2 от 1 до n.

var n,i,c:integer;
begin
writeln(“Input n”);
readln(n);
c:=1;
For i:=1 to n do
begin
c:=c*2;
writeln(c);
end;
end.
4. На вход программы подается число. Вывести его факториал.

var a,n:integer;
begin
writeln(“Input a”);
readln(a);
n:=1;
while a<>1 do
begin
n:=n*a;
a:=a-1;
end;
writeln(n);
end.
5. На вход программы подается число, отличное от 0. Определить сумму цифр в числе.

var a,s:integer;
begin
writeln(“Input a”);
readln(a);
s:=0;
repeat
begin
s:=s+(a mod 10);
a:=a div 10;
end;
until a=0;
writeln(s);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

17. напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех однозначных чисел, кратных 3. программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа не превышают 30 000. программа должна вывести одно число: сумму всех однозначных чисел, кратных 3.
Ваше имя (никнейм)*
Email*
Комментарий*