#include "stdafx.h"
#include < iostream>
using namespace std;
int main(int argc, char* argv[])
{
cout < < "obrabotka massiva" < < endl;
int array1[16] = { 5, -12, -12, 9, 10, 0, -9,
-12, -1, 23, 65, 64, 11, 43, 39, -15 }; // объявление и инициализация одномерного массива
cout < < "indeks" < < "\t\t" < < "element massiva" < < endl; // печать заголовков
for (int counter = 0; counter < 16; counter++) //начало цикла
{
//вывод на экран индекса ячейки массива, а затем содержимого этой ячейки, в нашем случае - это целое число
cout < < "array1[" < < counter < < "]" < < "\t\t" < < array1[counter] < < endl;
}
system("pause");
return 0;
}
определите операционную систему
5.1- а , d
6
функция 1: распределение вычислительных ресурсов, запуск и контроль выполнения программ, стандартными внешними устройствами, файлами.
функция 2: для обеспечения работы с дополнительными внешними устройствами в состав части операционной системы входят драйверы.
7
опишите почему появилось данное сообщение: оно появилась т.к на жестком диске нет места для нового файла
определите функцию, которую выполнила ос: она заблокировала копирование файла,из-за недостатка памяти
8
укажите вид беспроводной связи
8а: wi-fi беспроводная связь
8б: bluetooth(блютуз)
9
запишите 2 преимущества беспроводной связи
9.1: простота и скорость развертывания сети
9.2: отсутствие проводов на рабочем месте (хотя бы части проводов)
10
10.1 ик-порт: инфракрасный порт: телефон,пульт,компьютер
10.2bluetooth: беспроводная связь: телефон,компьютер
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу на языке c++ вам даётся 3 числа. требуется установить, возможно ли составить из них пифагоров треугольник. входные данные 3 целых числа, по модулю не превышающие 2 000 000 000. выходные данные если из чисел возможно составить пифагоров треугольник выведите "yes", иначе "no".
using namespace std;
int main() {
int a, b, c;
cout << "a, b, c: ";
cin >> a >> b >> c;
if ((a*a+b*b==c*c)||(a*a+c*c==b*b)||(b*b+c*c==a*a))
cout << "YES";
else cout << "NO";
return 0;
}
Пример:
a, b, c: 1960509751 395427000 1999990249
YES