aluka
?>

Робот движется по клетчатому полю в соответствии с заданой программой. для записи программы используется следующая система команд: 1. u# - # раз сместиться на одну клетку вверх. 2.d# - # раз сместиться на одну клетку вниз 3.r# - # раз сместиться на одну клетку вправо 4.l# - # раз сместиться на одну клетку влево 5.#{} - повторить # раз последовательность команд в скобках известно, что робот выполнил следующую программу: 10{u3 r3 u3 r3 d3 l3 d3 l6} сколько клеток поля робот посетил ровно два раза? в ответе укажите целое число.

Информатика

Ответы

aleksvasin

Создание диаграммы

Выберите данные для диаграммы.

На вкладке Вставка нажмите кнопку Рекомендуемые диаграммы.

На вкладке Рекомендуемые диаграммы выберите диаграмму для предварительного Примечание: Можно выделить нужные данные для диаграммы и нажать клавиши ALT+F1, чтобы сразу создать диаграмму, однако результат может оказаться не самым лучшим. Если подходящая диаграмма не отображается, перейдите на вкладку Все диаграммы, чтобы все типы диаграмм.

Выберите диаграмму.

Нажмите кнопку ОК.

Добавление линии тренда

Выберите диаграмму.

На вкладке Конструктор нажмите кнопку Добавить элемент диаграммы.

Выберите пункт Линия тренда, а затем укажите тип линии тренда: Линейная, Экспоненциальная, Линейный прогноз или Скользящее среднее.

Объяснение:

VEZZDEXOD73

// PascalABC.NET 3.4.2, сборка 1785 от 06.09.2018

// Внимание! Если программа не работает, обновите версию!

function RandomElement(m, n: integer; a: array[,] of integer) :=

   a[Random(0, m - 1), Random(0, n - 1)];


begin

 var (m, n) := ReadInteger2('Количество строк и столбцов в массиве:');

 Writeln('*** Исходный массив ***');

 var a := MatrRandom(m, n, -99, 99);

 a.Println(4); Println(4 * a.ColCount * '-');

 var s := 0;

 loop 4 do

   s += RandomElement(m, n, a);

 var p := 1;

 loop 9 do

   p *= RandomElement(m, n, a);

 Println('Сумма 4 случайных', s);

 Println('Произведение 9 случайных', p)

end.


Задан динамический двумерный массив. найти сумму четырех случайных элементов массива и произведение

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Робот движется по клетчатому полю в соответствии с заданой программой. для записи программы используется следующая система команд: 1. u# - # раз сместиться на одну клетку вверх. 2.d# - # раз сместиться на одну клетку вниз 3.r# - # раз сместиться на одну клетку вправо 4.l# - # раз сместиться на одну клетку влево 5.#{} - повторить # раз последовательность команд в скобках известно, что робот выполнил следующую программу: 10{u3 r3 u3 r3 d3 l3 d3 l6} сколько клеток поля робот посетил ровно два раза? в ответе укажите целое число.
Ваше имя (никнейм)*
Email*
Комментарий*