program ocenka; //название программы var a:integer; //целочисленная переменная оценки begin writeln(a); //ввод (с клавиатуры) значения оценки if (a=2) then writeln('Плохо') else writeln('Хорошо'); //условие (если а=2 - // ругаем, иначе - хвалим) end.
ОвчинниковаТатьяна
10.08.2022
Не знаю в каком языке программирования конкретно нужно, но в С# код программы в консольном варианте выглядит так Console.WriteLine("Введите предложение в котором присутствует 2 запятые");
string a = Console.ReadLine(); //Вводим текст в переменную а
string []B = a.Split(','); //разбиваем наше предложение на части по запятым и заносим их в массив
Console.WriteLine(""); // просто отделяем результат от остальной массы текста.
Console.WriteLine(B[1]); //И выводим результат на экран, все знаки между 2 запятыми.
Console.ReadLine(); Если нужно могу скинуть готовый фаил программы.
dmitryshigin
10.08.2022
Для С# код программы будет выглядеть так Console.WriteLine("Введите Х1 "); int a =Convert.ToInt16( Console.ReadLine()); Console.WriteLine("Введите Х2 "); int b = Convert.ToInt16(Console.ReadLine()); int c=0;
if (b>a) { for (int i = a; i < b - 1; i++) c += i + 1; } else { for (int i = b; i < a - 1; i++) c += i + 1; }
if (c == 0) Console.WriteLine("Между Х1 и Х2 елементов нету"); else Console.WriteLine("Сумма елементов между Х1 и Х2 = "+c); Console.ReadLine();
Если нужно могу скинуть exe-шный фаил с компилированной программой
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, в который выводят ответ: если вы получили 2, то вас ругают, а иначе хвалят
program ocenka; //название программы
var a:integer; //целочисленная переменная оценки
begin
writeln(a); //ввод (с клавиатуры) значения оценки
if (a=2) then writeln('Плохо') else writeln('Хорошо'); //условие (если а=2 -
// ругаем, иначе - хвалим)
end.