ooofishai4064
?>

Составьте программу на языке паскаль для вычесления значений следующих выражений: 1) d=y^15 2)k=x^19 3)l=(0.5+1/t)^2+1.8t.

Информатика

Ответы

jeep75
Var
   Y,X,T:real;
Begin
Write('Y = ');
ReadLn(Y);
Write('X = ');
ReadLn(X);
Write('T = ');
ReadLn(T);
WriteLn('D = ',Power(Y,15));
WriteLn('K = ',Power(X,19));
WriteLn('L = ',Sqr(0.5+1/T)+1.8*T );
End.
temik10808564

program fantscrin;

    var x_1,x_2,h,j,i: integer; f: boolean; a: array [1..3] of string; k,l: string;

    function chek_number(a: integer): boolean;

    var k: integer;

    begin

      if (a mod 2 < > 0) then  

                        begin  

                          chek_number: =false;

                          exit;

                        end;                  

      while a > 0 do

      begin

        a: =a div 10;

        k: =k+1;

      end;

      if (k = 3) then chek_number: =true

                else chek_number: =false;  

    end;

begin

    f: =false;

    while f = false do

    begin

      write('введите 1-ое число: '); readln(x_1);

      f: =chek_number(x_1);

    end;

    f: =false;

    while f = false do

    begin

      write('введите 2-ое число: '); readln(x_2);

      f: =chek_number(x_2);

      if (f) then if (x_1 < > x_2) then f: =true

                                  else f: =false;

    end;

   

    str(x_2,l);

    str(x_1,k);

    i: =1;

    h: =1;

    while i< =3 do

    begin

      j: =1;

      while j< =3 do

      begin

        if (k[i] = l[j]) then  

                        begin    

                            a[h]: =k[i];

                            h: =h+1;

                        end;

        j: =j+1;

      end;

      i: =i+1;

    end;

    writeln('');  

    i: =1;

    while i < =3 do

    begin

      write (a[i], '   ');

      i: =i+1;

    end;

end.

Чунихина1586

    f(x) = (x^2 -1)/(x^3 -1) = (x-1)(x+1) / (x-1)(x^2+x+1) = (x+1) / (x^2+x+1)  

f(1) = (1+1)/(1^2+1+1)=2/3  

 

но лучше так  

lim(x-> -1)(x^3-1)= lim(x-> 1-) ((x-1)(x+1) / (x-1)(x^2+x+1))=lim(x-> +1) / (x^2+x+1))=2/3  

lim(x-> 1+)(x^2-1)(x^3-1)= lim(x-> 1+) ((x-1)(x+1) / (x-1)(x^2+x+1))=lim(x-> 1++1) / (x^2+x+1))=2/3  

получаем, что x=1 - точка разрыва 1-го рода,  

но так как f(1-)=f(1+) - разрыв устранимый, потому что f(x) становится непрерывной, если положить f(1)=f(1-0)=f(1+0)=2/3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на языке паскаль для вычесления значений следующих выражений: 1) d=y^15 2)k=x^19 3)l=(0.5+1/t)^2+1.8t.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

timsch12
Рожнов
Vladimirovna1858
Бочкова_Елена203
vasiliiparshin7668
Вершинина1161
santechma
purchase
Aleksandrova Zhanna1250
taa19707470
ИП-Сысоев1628
airon-082054
dawlatowajana
elenabarskova7145
metelkin7338
▲