goodsled
?>

в составьте программу, находящую из трех чисел x, y, z наибольшее. сначала выбрать наибольшее число из двух – x, y и присвоить полученное значение переменной с, затем выбрать наибольшее из чисел с и z и присвоить полученное значение переменной c

Информатика

Ответы

zsa100
var x,y,z,c: integer;
begin
write('x, y, z:');
readln(x,y,z);
if x>y then c:=x else c:=y;
if z>c then c:=z;
writeln('c = ',c);
end.

Пример:
x, y, z:
5 8 4
c = 8
в составьте программу, находящую из трех чисел x, y, z наибольшее. сначала выбрать наибольшее число
shchepinasm

Объяснение:

1)Реферат (от лат. refero – докладываю) это самостоятельная научно-исследовательская работа, содержащая анализ различных взглядов на рассматриваемую проблему и раскрывающая ее суть. ... Структура реферата, как правило, включает, оглавление, введение, основную часть, заключение и список литературы.

2)Цвет шрифта должен быть черным, высота букв, цифр и других знаков не менее 1.8 (шрифт Times New Roman, 14 пт.). - Текст следует печазтать, соблюдая следующие размеры полей: верхнее и нижнее — 20 мм, левое — 30 мм, правое — 10 мм. Абзацный отступ должен быть одинаковым по всему тексту и составлять 1,25 см.

3)Поставьте курсор в начало созданной чистой страницы, затем перейдите по вкладке Ссылки — Оглавление. В появившемся окошке выберите Автособираемое оглавление 1 или Автособираемое оглавление 2. Щелкните по нему левой клавишей мыши.

4)Тут подготовься: https://multiurok.ru/files/kontrol-naia-rabota-po-informatikie-7-klass-obrabotka-tiekstovoi-informatsii.html

Nasteona1994

2)121514

Объяснение:

Предположим, у нас такие два числа: abc и xyz.  

Сумма старших разрядов: a+x

Сумма средних разрядов: b+y

Сумма младших разрядов: c+z

При этом сумма двух разрядов не может быть больше 18, так как максимальная цифра в 10-ной системе счисления 9, то максимальная сумма двух цифр = 9+9=18.

т.е мы сразу исключаем вариант 3 и 4 т.к. в них присутствуют суммы разрядов 19 и 21, а такого быть не может.

Также есть условие

К нему дописывается результат сложения средних разрядов по такому правилу: если он меньше первой суммы, то полученное число приписывается к первому слева, иначе – справа.

То есть получается, что две первые суммы разрядов записаны в порядке возрастания, а по такому условию, из двух оставшихся подходит только вариант 2

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

в составьте программу, находящую из трех чисел x, y, z наибольшее. сначала выбрать наибольшее число из двух – x, y и присвоить полученное значение переменной с, затем выбрать наибольшее из чисел с и z и присвоить полученное значение переменной c
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

soskadoa
Koranna1986
manimen345
Михайлович1309
slipu817838
Sergei Vitalevna
Д.О. Игорь
vera141187
e-s-i-k
litlenet
barnkim
stolle16
ГусенковФролова1121
marinadetsad
Volodka