kchapurina591
?>

Ябы хотел спросить у вас насчёт огэ по информатике.в номер 20.2 где надо написать программу например "программа должна вывести максимальное число из 5 и 7" как писать сами условия я знаю. а сами числа должны вводится с клавиатурычерез x=int( y=int( или уже равнятся x=5 y=7

Информатика

Ответы

Vikkitrip
/*Дано трехзначное число. Найти сумму и произведение его цифр. Вывести число, полученное при прочтении исходного числа справа налево. В нем зачеркнули первую слева цифру и приписали ее справа. Вывести полученное число. В нем зачеркнули первую справа цифру и приписали ее слева. Вывести полученное число. Вывести число, полученное при перестановке цифр сотен и десятков исходного числа (например, 123 перейдет в 213). Вывести число, полученное при перестановке цифр десятков и единиц исходного числа (например, 123 перейдет в 132).*/ #include <stdio.h> #include <clocale> void sp (int); //функция нахождения суммы и произведения цифр void sprnl (int); //функция прочтения числа справа налево void pervsl (int); //функция 3 :D void pervsp (int); //функция 4 :P void sotdes (int); //функция перестановки сотен и десятков void desedin (int); //функция перестановки десятков и единиц int main() { setlocale (2, ".1251"); int num; do { printf ("Введите число: "); while (!(scanf("%d", &num)) || num < 100 || num > 999) { fflush(stdin); printf ("\nОшибка. Введите заново: "); } sp (num); sprnl (num); pervsl (num); pervsp (num); sotdes (num); desedin (num); printf ("\n\n"); } while (1); return 0; } void sp (int a) { int sum=0, mult=1; while (a) { sum+=a%10; mult*=a%10; a=a/10; } printf ("\n\nСумма цифр равна: %d", sum); printf ("\nПроизведение цифр: %d", mult); } void sprnl (int num) { int a, b, c; a=num%10; num/=10; b=num%10; num/=10; c=num%10; printf ("\nПеревернутое число: %d", 100*a+10*b+c); } void pervsl (int num) { int a, b; a=num%100; b=num/100; printf ("\nЗачеркнули первую слева цифру и приписали ее справа: %d", a*10 + b); } void pervsp (int num) { int a, b; a=num%10; b=num/10; printf ("\nЗачеркнули первую справа цифру и приписали ее слева: %d", a*100 + b); } void sotdes (int num) { int a, b, c; a=num%10; num/=10; b=num%10; num/=10; c=num%10; printf ("\nПерестановка сотен и десятков: %d", b*100 + c*10 + a); } void desedin (int num) { int a, b, c; a=num%10; num/=10; b=num%10; num/=10; c=num%10; printf ("\nПерестановка десятков и единиц: %d", c*100 + a*10 + b);
Alekseevna1064
1)
 var 
n:integer;
begin 
readln(n); 
if(n<0)then write(0) 
else write(n+4);
end.

2)
 var
  a, b: integer;
 begin
  readln(a, b);
  if(a = b) then
write(1)
  else
write(0);
end.

3)
var
  a, b, c, s: integer;
 begin
  s := 0;
  readln(a, b, c);
  if(a >= 0) then s := s + 1;
  if(b >= 0) then s := s + 1;
  if(c >= 0) then s := s + 1;
  write(s);
end.

4)
var
  a, b, c, s: integer;
 begin
  s := 0;
  readln(a, b, c);
  if(a > 0) then s := s + a;
  if(b > 0) then s := s + b;
  if(c > 0) then s := s + c;
  write(s);
end.
5)
 var
  a, b, c: integer;
 begin
  readln(a, b, c);
  if (a < b) then swap(a, b);
  if (a < c) then swap(a, c);
  if (b < c) then swap(b, c);
  write(a, ' ', b, ' ', c);
end.

6)
 var n, k, s, i: integer;
 begin
  s := 0;
  readln(n, k);
  for i := 1 to n.ToString.Length do
  if(strtoint(n.ToString[i]) > k) then s := s + strtoint(n.ToString[i]);
  write(s);
 end.

7)
 var n, s, i: integer;
 begin
  s := 0;
  readln(n);
  for i := 1 to n do
    s := s + i;
  write(s);
 end.

9)
 var n, i: integer;
 begin
  readln(n);
  for i := n downto 1 do
  write(i);
 end.

12
 var
  n, i: integer;
  s: real;
 begin
  s := 0;
  readln(n);
  for i := n downto 1 do
  s:=s+(0.1*i);
    write(s);
 end.

13)
 var n, i: integer;
 begin
  readln(n);
  for i := 1 to n do
    write(sqr(i), ' ');
end.

14)
 var
  n, i, c: integer;
 begin
  i := 1;
  c := 0;
  readln(n);
  while (c <> n) do
  begin
    if(i mod 3 = 0) then begin write(i, ' ');c := c + 1; end;
    i := i + 1;
  end;
end.

15)
 var
  n, i, a: integer;
  c: real;
 begin
  i := 1;
  c := 0;
  readln(n);
  for i := 1 to n do
   begin
    read(a);
    c := c + a;
  end;
  write(c / n)
end.

16)
 var
  n, i, a: integer;
 begin
  i := 1;
  while true do
   begin
    read(a);
    if(a = 0) then break;
    n := n + 1;
  end;
  write(n)
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Ябы хотел спросить у вас насчёт огэ по информатике.в номер 20.2 где надо написать программу например "программа должна вывести максимальное число из 5 и 7" как писать сами условия я знаю. а сами числа должны вводится с клавиатурычерез x=int( y=int( или уже равнятся x=5 y=7
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Blekjek730
germanleon
tatry2005
ecocheminnov437
verkop9
Mbkozlov6
ASRodichev
kisuhakisa
vallzh8328
Lolira64
Валентинович133
lider-mpl550
Анатольевич-Фатима
Yevgenevna
sohrokova809