Ты сам себе противоречишь 1 ты не указал какие переменные должны быть 2 тут прога такая если а<5 тогда с=5 если а >5 тогда с=2 иначе с=3 ( а ты указал в иначе с=1) вот что тебе предлагаю if a<5 then c:=1 else c:=2
iplizogub74
12.05.2023
Для всех заданий воспользуемся формулой N=2^i? где N -количество цветов, а i -количество бит на 1 пиксель. Задача 1. N=2^4=16 цветов.
Задача 2. N=224=2^i, поскольку для кодирования 128 цветов необходимо 7 бит, а для кодирования 256 цветов -8 бит, выбираем большее число, то есть 8 бит или 1 байт.
Задача 3. 65536 это 2^16⇒требуется 16 бит или 2 байта.
Задача 4. 1. Узнаем общее количество пикселей 1280*1024=1310720 2. Полученное число умножаем на глубину цвета 1310720*32=41943040 бит = 41943040/8 = 5242880 байт = 5242880/1024 = 5120 кб =5120/1024 = 5 Мб ответ: 5 Мб
Олеся
12.05.2023
//Pascal var a,b, I, maxsumm, max : integer;
function summdel(x:integer):integer; //результат - сумма делителей х var k,sum:integer; begin sum:=0; for k := 1 to x div 2 + 1 do if x mod k = 0 then sum:= sum+k; summdel:=sum; end;
begin writeln('Введите границы a,b '); readln(a,b); maxsumm := 1; max := 1; for i := a to b do begin if summdel(i) > maxsumm then begin maxsumm:= summdel(i); max := i; end; end; writeLn('Максимальная сумма делителей - ', maxsumm, ' число - ',max) end.
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Можно фото напишите программу , вставя туда отрывок if a< 5 then c: =1 if a> 5 then c: =2 else c: =3
1 ты не указал какие переменные должны быть
2 тут прога такая
если а<5 тогда с=5
если а >5 тогда с=2 иначе с=3 ( а ты указал в иначе с=1)
вот что тебе предлагаю
if a<5 then c:=1
else
c:=2