1 Встроенные объекты являются фундаментом языка, на котором строится специализированный код. Они используются для того, чтобы реализовать функциональность придиктованную вашим воображением. Меню, область моделирования, сторона заголовка, панели инструментов, строка.
2 Вот такие внутренние объекты, стандартные модули программы называются встроенными объектами или процедурами. Такие внутренние процедуры имеются и в SketchUp. В программе SketchUp при создании 3D-моделей с инструментов используются вставка, заливка и шаблон, чтобы показать созданный объект в реальном режиме.
3 не знаю прости
Объяснение:
По... У меня в школе был corel draw. Не знаю что сейчас у вас изучают.
Можно открыть книжечку и прочитать, что в векторном изображении нету понятия пикселя. Всё представляется на основе размера "холста" и положения отступов от границ, размера примитива и его угла поворота, ширины и высоты. А раз нету понятия пикселя, значит такое изображение можно не только сжимать, как расстровое, но и прекрасно увеличивать. Если ты сделаешь любую картинку в векторном редакторе, её можно будет напечатать на холсте размером с нашу Солнечную систему, но качество будет таким-же идеальным.
Это очень удобно и круто, когда речь идет о компьютерных играх, ведь любое изображение, текстура, лицо персонажа, одежда перса и т.д. формируются на основе примитивов и кривых (мой любимый пример - Fall guys. Там все элементы собраны из примитивов на основе векторной 3д крафики. Всё округлое, красивое и равномерно окрашено)
В печати частенько использую векторную графику (разметка страницы, оформление, логотипы и т.д. для всяких глянцевых и не только журналов)
Эффективность раскрыта выше. Это работает и этим пользуются повсеместно
Поделитесь своими знаниями, ответьте на вопрос:
Дан массив a(n определите количество четных элементов с четными индексами, кратных 7. выведите на экран исходный массив и полученное количество.
var a:array[1..n] of integer;
i,k:integer;
begin
Randomize;
writeln('Массив A:');
for i:=1 to n do
begin
a[i]:=random(51);
write(a[i]:4);
end;
writeln;
k:=0;
for i:=1 to n do
if (a[i] mod 2=0)and(a[i] mod 7=0)and(i mod 2=0) then k:=k+1;
writeln('k = ',k);
end.
Пример:
Массив A:
25 29 13 39 9 14 27 16 12 45
k = 1