Нужно написать программу на языке с++: дана последовательность целых чисел, за которой следует 0. найти разность минимального и максимального элементов в этой последовательности.
#include<iostream> using namespace std; int main() { int A; cin >> A; int Min = A; int Max = A; while(A) { cin >> A; if (Max < A && A!=0) Max = A; if (Min > A && A!=0) Min = A; } cout <<"Min = "<<Min<<"\n"; cout <<"Max = "<<Max<<"\n"; cout <<"Min - Max = "<<Min-Max<<"\n"; return 0; }
Maionova
25.05.2023
Вот тебе простой вариант ришение задачи (коментар=пояснение)
PascalВыделить код
1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 program prg; uses crt; var rez,chislo,min,max:integer; begin Write('Enter number = ');readln(chislo); //zanosim 1 chislo max:=chislo; //v max ta min min:=chislo; //chtobu potom mu soukb sravnivat s drugimi chislamu while (chislo<>0) do //zapuskaem zikl poka mu ne napishem 0 begin if (chislo>max)then max:=chislo; //sravnivaem s max if (chislo<min) then min:=chislo; //sravnivaem s min readln(chislo); //snova pihem chislo end; rez:=(max-min); //nahodim raznizy writeln('max(',max,') - min(',min,') = ',rez); //otvet end.
Alekseevich_Viktorovna
25.05.2023
Const n=12; m=10; var a:array[1..n,1..m] of integer; i,j,k:integer; begin k:=0; for j:=1 to m do for i:=n downto 1 do begin k:=k+1; a[i,j]:=k; end; for i:=1 to n do begin for j:=1 to m do write(a[i,j]:4); writeln; end; end.
Нужно написать программу на языке с++: дана последовательность целых чисел, за которой следует 0. найти разность минимального и максимального элементов в этой последовательности.
using namespace std;
int main()
{
int A;
cin >> A;
int Min = A;
int Max = A;
while(A)
{
cin >> A;
if (Max < A && A!=0) Max = A;
if (Min > A && A!=0) Min = A;
}
cout <<"Min = "<<Min<<"\n";
cout <<"Max = "<<Max<<"\n";
cout <<"Min - Max = "<<Min-Max<<"\n";
return 0;
}