andyrvo
?>

Написать программу по программированию напишите программу которая в последовательности целых чисел определяет количество чисел оканчивающихся на 5 или кратных 3.программа получает на вход целое числа количество введённых чисел неизвестно последовательность заканчивается числом 0 (0-признак окончание ввода, не входит в последовательность) количество чисел не превышает 1000.введённые числа по модулю не превышают 30000. программа должна вывести одно число: количество чисел оканчивающихся на 5 или кратно 3.

Информатика

Ответы

petrowich076813
Var A,k:integer;
Begin
k:=-1;
Repeat
Read(A);
if (Abs(A) mod 10 = 5)or(A mod 3 = 0) then k:=k+1;
Until A = 0;
Write(k)
End.
galinasemyan689
Program aaa;
var
Y:array[1..1000,1..1000] of longint;
n,m,i,j,count5,countm9,s5,sm9:longint;
begin
writeln('введите размерность массива');
read(n,m);
writeln('введите массив');
for i:=1 to n do
 for j:=1 to m do
   read(Y[i,j]);
count5:=0;
countm9:=0;
s5:=0;
sm9:=0;
for i:=1 to n do 
for j:=1 to m do
 begin
  if Y[i,j]>5 then
      begin 
       inc(count5);
       s5:=s5+Y[i,j]
      end;
  if Y[i,j]<-9 then 
      begin 
        inc(countm9);
        sm9:=sm9+Y[i,j]
      end;
  end;
writeln('всего элементов больше 5:',count5,' ,сумма этих элементов равна:',s5);
writeln('всего элементов меньше -9:',countm9,' ,сумма этих элементов равна:',sm9)
end.
Alekseeva_Khlistov

Объяснение:

По представления состояния системы различают: 1. Дискретные модели –– это автоматы, то есть реальные или воображаемые дискретные устройства с некоторым набором внутренних состояний, преобразующие входные сигналы в выходные в соответствии с заданными правилами. 2. Непрерывные модели –– это модели, в которых протекают непрерывные процессы. Например, использование аналоговой ЭВМ для решения дифференциального уравнения, моделирования радиоактивного распада с конденсатора, разряжающегося через резистор и т.д. По степени случайности моделируемого процесса выделяют (рис. 1): 1. Детерминированные модели, которым свойственно переходить из одного состояния в другое в соответствии с жестким алгоритмом, то есть между внутренним состоянием, входными и выходными сигналами имеется однозначное соответствий (модель светофора). 2. Стохастические модели, функционирующие подобно вероятностным автоматам; сигнал на выходе и состояние в следующий момент времени задается матрицей вероятностей. Например, вероятностная модель ученика, компьютерная модель передачи сообщений по каналу связи с шумом и т.д.

анализ и интерпретация результатов, их сопоставление с эмпирическими данными. Затем все это повторяется на следующем уровне.

Разработка компьютерной модели объекта представляет собой последовательность итераций: сначала на основе имеющейся информации о системе S строится модель , проводится серия вычислительных экспериментов, результаты анализируются. При получении новой информации об объекте S учитываются дополнительные факторы, получается модель , поведение которой тоже исследуется на ЭВМ. После этого создаются модели ,  и т.д. до тех пор, пока не получится модель, с требуемой точностью соответствующая системе S.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу по программированию напишите программу которая в последовательности целых чисел определяет количество чисел оканчивающихся на 5 или кратных 3.программа получает на вход целое числа количество введённых чисел неизвестно последовательность заканчивается числом 0 (0-признак окончание ввода, не входит в последовательность) количество чисел не превышает 1000.введённые числа по модулю не превышают 30000. программа должна вывести одно число: количество чисел оканчивающихся на 5 или кратно 3.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

sve34166163
Shlapakov1911aa
burylin9
saa002
Kelena190533
kuznecovav3066
yorestov
Nekrasova
zinasekina4
allaraygor
ipaskarovanv6
Sergei
andreyshulgin835
Алина Ракитин1730
martinson1136