treneva359
?>

Написать программу в си подсчитать, сколько букв надо исправить в слове х, чтобы получилось слово y (х, y - слова одинаковой длины

Информатика

Ответы

Yevsyukov1697
#include<iostream>
#include<string>
#include<locale>
using namespace std;

int main()
{    
    setlocale(LC_CTYPE,"RUS");
    cout <<"Ââåäèòå äâà ñëîâà ðàâíîé äëèíû:"<<"\n";
    string X,Y;
    int k = 0;
    cin >> X >> Y;
    for(int i = 0; i<=X.length(); i++)
    {
        k+=(X[i]!=Y[i]);
    }
    cout << k <<"\n";
    return 0;
}
rozhkova

1) a = 12;

2) a= 16;

3) i = 6;

4) c = 6;

5) a = 22;

6) a = 15;

7) a = 3;

8) 5=Z(3) ;

9) a = 8;

10) a = 14;

11) a = 12;

12) Z(a)=(b) ;

13) i = 3;

Объяснение:

1) Программа не войдет в цикл т.к. i = 3 => значение а не изменится.

2) a = 4;  a + a = 8; a + a = 16

3) Цикл выполнится 4 раза в том случае, если значение i будет на 3 больше, чем в условии, т.к. установлено >= и за цикл из i вычитается 1.

4) a = 20; b = 3; b = 20/3 (без остатка) = 6; с = 20/7 (только остаток) = 6.

5) a = 10; т.к. a<15, то a = a + 12 = 10 + 12 = 22;

6) a = 10; т.к. a > 5, то a = a -7 = 10 - 7 = 3; т.к. a < 5, то a = a + 12 = 3 + 12 = 15.

7) a = 10; т.к. a > 5, то a = a - 7 = 10 - 7 = 3.

8) 5=Z(3)

9) a = 10; a = 10 - 1 = 9; a = 9 - 1 = 8

10) a = 12; т.к. i = 2, что меньше чем 3, то цикл сработает 1 раз (т.к. внутри его i увеличится на 1) => a = a + i = 12 + 2 = 14.

11) a = 10; т.к. a > 5, то a =12. ( не знаю, нужна ли там ; после then, но в любом случае ответ будет такой)

12) Z(a)=(b)

13) Цикл выполнится 2 раза в том случае, если значение i будет на 1 больше, чем в условии, т.к. установлено >= и за цикл из i вычитается 1.

Fedorovich309

1. Расчертить все поле горизонтальными пунктирными линиями.

НАЧ

ПОКА впереди НЕ стена

НЦ

ДЕЛАЙ линия

ДЕЛАЙ правый переход

ДЕЛАЙ линия

ДЕЛАЙ левый переход

КЦ

КОН

ПРОЦЕДУРА линия

ПОКА впереди НЕ стена

НЦ

ШАГ

ЕСЛИ впереди НЕ стена

ТО

ПРЫЖОК

ВСЁ

КЦ

КОНЕЦ ПРОЦЕДУРЫ

ПРОЦЕДУРА правый переход

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ЕСЛИ впереди НЕ стена

ТО

ПРЫЖОК

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ВСЁ

КОНЕЦ ПРОЦЕДУРЫ

ПРОЦЕДУРА левый переход

ПОВОРОТ

ЕСЛИ впереди НЕ стена

ТО

ПРЫЖОК

ПОВОРОТ

ВСЁ

КОНЕЦ ПРОЦЕДУРЫ

2) Нарисовать квадраты во всех углах поля.

НАЧ

ДЕЛАЙ квадрат

ДЕЛАЙ переход

ДЕЛАЙ квадрат

ДЕЛАЙ переход

ДЕЛАЙ квадрат

ДЕЛАЙ переход

ДЕЛАЙ квадрат

КОН

ПРОЦЕДУРА квадрат

ШАГ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ШАГ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ШАГ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

ШАГ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

КОНЕЦ ПРОЦЕДУРЫ

ПРОЦЕДУРА переход

ПОКА впереди НЕ стена

НЦ

ПРЫЖОК

КЦ

ПОВОРОТ

ПОВОРОТ

ПОВОРОТ

КОНЕЦ ПРОЦЕДУРЫ


Что такое пошаговая детализация? из каких команд могут состоять алгоритмы последнего уровня детализ
Что такое пошаговая детализация? из каких команд могут состоять алгоритмы последнего уровня детализ

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в си подсчитать, сколько букв надо исправить в слове х, чтобы получилось слово y (х, y - слова одинаковой длины
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

MN-Natusik80
alexfold
I.B.Petrishchev
krasnova1977
spz03
adminkuncevo
SEMENOV25352
ИванМолчанов
ismailovi670771
safin8813
Анна Марина1873
stic1995
Anait_Natalya451
fishka-sokol14
Avdimov5
▲