ulyana-d
?>

Написать программу на языке паскаль. с клавиатуры вводятся несколько натуральных целых чисел. необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел. например: вводим числа 3425 - получает количество чисел - 4, количество четных чисел - 2, сумма чисел - 14

Информатика

Ответы

irina-mic
Var
  n, m, p, k, sum, x: integer;
  s: string;
  c, i: byte;

begin
  write('Число: ');
  read(n);
  m := n;
  k := 0;
  while m <> 0 do
  begin
    p := m mod 10;
    K := K + 1;
    m := m div 10;
  end;
 
  Str(N, s);
  c := 0;
  for i := 1 to Length(s) do
    if s[i] in ['0', '2', '4', '6', '8'] then
      Inc(c);
 
  x := n;
  sum := 0;
  while (x <> 0 ) do
  begin
    sum := sum + (x mod 10);
    x := x div 10;
  end;
 
  writeln('Количество чисел: ', k);
  writeln('Количество четных чисел: ', c);
  writeln('Cумма чисел : ', sum);
end.
КараханянКусков
41)Создать новую таблицу
42) Д)
43)Правка - Удалить запись.
50) Параметры.
53)Выводится диалоговое окно с приглашением ввести параметр для условия на отбор записей.
56)Изменяются значения в полях определенных записей.
57)Создается таблица с данными, соответствующими определенным условиям.
62)Автоматической вставки последовательных или случайных чисел в качестве номера новой записи.
65)Во вкладке Режим таблиц – выбрать Вставить 
66)Разные имена, но одинаковый тип данных.
69)Для отбора записей, данные в которых соответствуют определенным условиям.
70)Е)
71)Для создания контрольного переключателя.
varvara-kulkova

ответ: 1 - c, 2 -b, 3 - b, 4 - b, 5 - a, b, 6 - a, 7 - a, 8 - a, 9 - b, 10 - b, 11 - e, 12 - b, 13 - c, 14 - b, d, e.

Объяснение:

1. Информационная услуга — это получение и предоставление в распоряжение пользователя информационных продуктов.

2. Информационно-поисковые системы позволяют осуществлять поиск и сортировку данных.

3. В чем отличие информационно-поисковой системы (ИПС) от системы управления базами данных (СУБД)? -  в отсутствии инструментов сортировки и поиска.

4. WORD — это текстовый процессор.

5. ACCESS реализует —  реляционную или иерархическую структуру данных.

6. Электронные таблицы позволяют обрабатывать цифровую информацию.

7. Схему обработки данных можно изобразить посредством  коммерческой графики.

8. Векторная графика обеспечивает построение геометрических фигур.

9. Деловая графика включена в состав Excel.

10. Структура гипертекста задается заранее и является иерархической.

11. Гипертекст – это технология поиска по смысловым связям.

12. Единицей обмена физического уровня сети является бит.

13. Протокол IP сети используется на сетевом уровне.

14. Интернет возник благодаря соединению таких технологий, как гипертекст, сетевые технологии, телеконференции.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на языке паскаль. с клавиатуры вводятся несколько натуральных целых чисел. необходимо чтобы вычислялось сколько введено чисел, сколько из них четных и общая сумма этих чисел. например: вводим числа 3425 - получает количество чисел - 4, количество четных чисел - 2, сумма чисел - 14
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

natabodrikova
andrewa
kulturarai44
ambstroy
Roman343247
Inozemtseva Korolev1271
fokolimp
Ohokio198336
morozova
Galina
myxa120283
scorpion21c
TatianaSeliverstova64
Georgievich-Zamudinovna2003
Дементьева-Артем1315