julya847
?>

По м о г и т е, п о ж а л у й с т ! 1) вводится массив, состоящий из целых чисел. найти наибольшее среди них. входные данные сначала задано число n — количество элементов в массиве (1n35 далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести значение наибольшего элемента в массиве. примеры входные данные 3 1 2 3 выходные данные 3 2) напишите программу, которая циклически сдвигает элементы массива вправо (например, если элементы нумеруются, начиная с нуля, то 0-й элемент становится 1-м, 1-й становится 2-м, последний становится 0-м, то есть массив {3, 5, 7, 9} превращается в массив {9, 3, 5, 7}). входные данные сначала задано число n — количество элементов в массиве (1n35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести массив, полученный после сдвига элементов. примеры входные данные 6 4 5 3 4 2 3 выходные данные 3 4 5 3 4 2

Информатика

Ответы

dashkevich-76611
var a: array [1..100] of integer; i,  n ,  max : integer; begin writeln('rozmer'); readln(n); randomize ; if (( n>=1) and (n<=35)) then for i:=1 to n do begin a[i]:=random(90)-45 ; write(a[i]:3); end; writeln; max:=a[1] ; for i:=2 to 100 do begin if a[i]>max then max:=a[i] ; end; writeln(max); end.
Сурат1199

Ақпараттық технологиялар саласы негізінен екі тәуелсіз циклде дамиды: өнімділік және қаржылық. Жақында біз қаржылық циклде екендігіміз туралы көптеген даулар болды; қаржылық нарықтарға көп көңіл бөлінеді, олар кейде өзін болжай алмайтындай ұстайды және қатты өзгеріп отырады. Екінші жағынан, өнімнің циклдеріне онша назар аударылмайды, дегенмен олар ақпараттық технологияны алға жетелейді. Бірақ өткен тәжірибені талдай отырып, сіз қазіргі өнім циклын түсінуге және технологиялардың болашақ дамуын болжауға тырыса аласыз. Жоғары технологиялар саласындағы өнім циклдарының дамуы платформалар мен қосымшалардың өзара әрекеттесуі арқылы жүреді: жаңа платформалар жаңа қосымшаларды құруға мүмкіндік береді, бұл өз кезегінде осы платформалардың құнын арттырады, осылайша оң кері байланыс циклін жабады. Шағын өнім циклдары үнемі қайталанып отырады, бірақ тарихи түрде 10-15 жылда бір рет тағы бір үлкен цикл басталатындай дамыды - бұл АТ-ны толық өзгертетін дәуір.

Объяснение:

Tatyana_Minullina
Дорога, соединяющая города i и j, даст единицу в две позиции - (i, j) и (j, i). Тогда общее количество единиц в матрице равно удвоенному числу дорог. Отсюда и простое решение - считать N^2 чисел, подсчитать количество единиц и поделить его на 2. Можно считать и сумму - от этого ничего не изменится.

   #include <iostream> 
   int main() {
       int n = 0, sum = 0, temp = 0;
       std :: cin >> n;
       for (int i = 0; i < n * n; i++) {
           std :: cin >> temp;
           sum += temp;
       }
       std :: cout << sum / 2;
       return 0;
   }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

По м о г и т е, п о ж а л у й с т ! 1) вводится массив, состоящий из целых чисел. найти наибольшее среди них. входные данные сначала задано число n — количество элементов в массиве (1n35 далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести значение наибольшего элемента в массиве. примеры входные данные 3 1 2 3 выходные данные 3 2) напишите программу, которая циклически сдвигает элементы массива вправо (например, если элементы нумеруются, начиная с нуля, то 0-й элемент становится 1-м, 1-й становится 2-м, последний становится 0-м, то есть массив {3, 5, 7, 9} превращается в массив {9, 3, 5, 7}). входные данные сначала задано число n — количество элементов в массиве (1n35). далее через пробел записаны n чисел — элементы массива. массив состоит из целых чисел. выходные данные необходимо вывести массив, полученный после сдвига элементов. примеры входные данные 6 4 5 3 4 2 3 выходные данные 3 4 5 3 4 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

savenko0109152
impuls20125948
autofilters27
Константин Андрей
dannytr
Staroverovanatasa494
anusha33325
Васильевий
YelenaZOLTANOVICh105
nastikak8
galinab1111326
Letajushaya362
master-lamaster
juliaydodova
uchpapt