Модель (фр. modele, лат. modulus – өлшем)[1] – белгілі бір зерттелетін нысанның ой түсінігі арқылы немесе материалдық түрде жасалған шартты үлгісі (бейнесі, сұлбасы, сипаттамасы, т.б.). Модель мен түп нұсқаны бір-бірінен абсолютті түрде айыруға болмайды. Қарастырылып отырған құбылыс немесе процесс абстрактылық нысандар мен математикалық заңдылықтар түрінде берілетін модель математикалық модель деп аталады. Модельдің ең қарапайым түрі нысандарды көрнекі етіп сурет, кескін, сызба формасында графиктік түрде көрсету. Модельдің екінші түріне – нысандардың, процестер мен құбылыстардың ауызша (қандай да бір тілдің көмегімен) суреттелуі, сипатталуы жатады. Үшінші түрі –ақпараттық-логикалық модель, ауызша сипатталған нысанды кескіндеп көрсету (формалау). Төртінші түрі – динамиканың ішкі заңдарын, өзара әсерін, қасиеттерін көрсететін физикалық нысандардың, құбылыстар мен процестердің математикалық түрде сипатталуы. Мысалы, белгілі бір физикалық процестің уақыт ішінде өтуін баяндайтын дифференциялдық теңдеулер жүйесі осы процестің моделі деп аталады. Модель ұғымы логика, математика, физика, химия, кибернетика, лингвистика, т.б. ғылым салаларында қолданылады. Ғылымда модель ұғымы әдетте модель жасау әдісін қолдануға байланысты аталады. Алгебра мен математика логиканың тоғысқан жерінде арнаулы пән – модельдер теориясы қалыптасты.[2]
#include "stdafx.h"
#include "stdio.h"
#include <time.h>
#include <stdlib.h>
class vector
{
private:
int* m;
int size;
public :
vector(int n = 0);
vector(const vector &vector2);
~vector();
};
vector::vector( int n )
{
if (n < 0) n = 0;
size = n;
m = new int[n];
if(!m)
printf("Error");
else
m = NULL;
}
vector::vector(const vector &vector2)
{
size = vector2.size;
m = new int [size];
for(int i = 0; i<size;i++)
m[i] = vector2.m[i];
printf("Hello world !");
}
vector::~vector()
{
delete[] m;
}
vector(int *m, int size)
{
srand(time(NULL))
if(!m)
printf("error")
else
for(int i = 0; i < size; i++)
m[i] = rand()% 99;
}
int main()
{
vector v1(45),
system("pause");
return 0;
}
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Help! нужно написать программу на языке с# * заданы 2 строки, состоящие из слов, разделенных пробелами. если второе слово первой строки такое же, как второе слово второй строки, то поменять порядок следования символов первой строки на противоположный, в противном случае заменить все символы второй строки на “! ”