prohorovalena
?>

Составьте программу для нахождения среднего арифметического всех натуральных чисел на отрезке [50; 180]

Информатика

Ответы

Сорокина
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln(Range(50,180).Average:0:2)
end.

Результат
115.00
vahmistrova
#include <iostream>
#include <iomanip>
#include <cstdlib>

using namespace std;

int main() {

  bool priz;
  int n;
  cout<< "n = ";  cin>>n;
  int *a = new int[n];
  srand(time(NULL));
  for (int i=0;i<n;i++) {
     a[i]=rand()%101-50;
     cout<<a[i]<<" ";
     if (a[i]<0) a[i] = - a[i];
  }
  cout<<endl;
//  сортировка массива
   while (priz)   
   {
      priz=false;
      for (int i=1; i<n; i++)
      if (a[i]<a[i-1]) 
         {  swap(a[i],a[i-1]);  priz=true;  }
   }
// вывод массива
   cout<<"new array"<<endl; 
   for (int i=0; i<n; i++)
      cout<<a[i]<<" ";
   cout<<endl;
   system("pause");
   return 0;
}
boro-1973
//VS C++

#include <iostream>
#include <time.h>
using namespace std;
int main() {
    int *A;
    int N;
    setlocale(LC_ALL, "Russian");
    srand(time(NULL));

    cout << "Количество элементов в массиве: "; cin >> N;
    A = new int[N];
    cout << "***Исходный массив***" << endl;
    for (int i = 0; i < N; i++) {
        A[i] = rand() % (101) - 50;
        cout << A[i] << " ";
    }
    cout << endl;
    cout << "***Измененный массив***" << endl;
    for (int i = 0; i < N; i++) {
        if (A[i] < 0) A[i] = -A[i];
        cout << A[i] << " ";
    }
    cout << endl;
    int temp;
    //Сортировка массива пузырьком
    cout << "***Измененный отсортированный массив***" << endl;
    for (int i = 0; i < N - 1; i++) {
        for (int j = 0; j < N - i - 1; j++) {
            if (A[j] > A[j + 1]) {
                temp = A[j];
                A[j] = A[j + 1];
                A[j + 1] = temp;
            }
        }
    }
    for (int i = 0; i < N; i++) cout << A[i] << " ";
    cout << endl;
    system("pause");
    return 0;
}

Дан одномерный целочисленный массив, заданный случайными числами на промежутке [-50; 50]. заменить в

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу для нахождения среднего арифметического всех натуральных чисел на отрезке [50; 180]
Ваше имя (никнейм)*
Email*
Комментарий*
▲