taanaami75
?>

Напишите программу в pascal abc, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: количество чисел, кратных 5 или 9. входные данные: 15 91 90 0 выходные данные: 2

Информатика

Ответы

yurogov61
Var a,k:integer;
begin
k:=0;
readln(a);
while a<>0 do
 begin
 if (abs(a) mod 5=0)or(abs(a) mod 9=0)
  then k:=k+1;
 readln(a);
 end;
writeln('k = ',k);
end.

Пример:
15
91
90
0
k = 2
polina25258

Эффект по буквам Кликнем по тексту — вокруг него появится рамка.

Во вкладке «Анимация» выберем «Появление», а в подменю  «Параметры эффектов» — «Слева».

Объяснение:

Затем откроем область анимации и вызовем меню «Параметры эффектов».

ПАРАМЕТРЫ

Когда откроется вкладка «Появление», в подменю «Эффекты» в строке «Анимация текста» выберите «По буквам».

Обратите внимание, что в окне ниже имеется возможность установить % задержки между буквами — т.е. скорость появления текста.  

Кроме того, в подменю «Время» тоже можно регулировать продолжительность появления текста от «Очень быстро» до «Очень медленно». Я поставила здесь  10 сек.

Кочугурова
DIM a AS SINGLE, b AS SINGLE, h AS SINGLE
DIM x AS SINGLE, y AS SINGLE
CLS
INPUT "Vvedite a,b,h: ", a, b, h
FOR x = a TO b STEP h
   y = 1 / 2 * LOG(x ^ 2) + 1 / x ^ 2 + 2 - 1 / 2 * LOG(2) / 3
   PRINT "x="; x, "y="; y
NEXT x
END

Тестовое решение:
Vvedite a,b,h: 2.7,8.4,0.5
x= 2.7        y= 3.014901
x= 3.2        y= 3.145283
x= 3.7        y= 3.265854
x= 4.2        y= 3.376249
x= 4.7        y= 3.477307
x= 5.2        y= 3.570116
x= 5.7        y= 3.65572
x= 6.2        y= 3.735039
x= 6.7        y= 3.80886
x= 7.2        y= 3.877846
x= 7.7        y= 3.942562
x= 8.2        y= 4.003482

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в pascal abc, которая в последовательности целых чисел определяет количество чисел, кратных 5 или 9. программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность количество чисел не превышает 1000. введённые числа по модулю не превышают 30 000. программа должна вывести одно число: количество чисел, кратных 5 или 9. входные данные: 15 91 90 0 выходные данные: 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

vakhitov100961
ludmila-malev280
apro3444595
evge-borisova2
goryavinan
Veselova
vdk81816778
BelozerovaGeller648
ivnivas2008
whitewhit90
orantus3
Назаров588
смирнов1127
Lianchikavon
proh-dorohova5244
▲