begin s := 0; i := 0; read(n); repeat i := i + 1; if(i mod 2 <> 0) then s := s + i; until i = n; write(s); end.
Olesya
04.09.2022
1) Частота дискретизации 44.1 кГц означает, что в секунду делается 44 100 отсчетов. Разрешение 16 бит (т.е. 16/8=2 байта) требует для хранения каждого отсчета 2 байта, а для хранения информации за 1 секунду - 2 х 44 100 = 88 200 байт. Две минуты - это 2 х 60 = 120 секунд и тогда общий объём составит 88 200 х 120 = 10 584 000 байт или 10 584 000 / 1024 = 10 335.94 Кбайт, или 10 335.94 / 1024 = 10.1 Мбайт И все это - для одного канала записи (монофонической). Если запись стереофоническая - то каналов два и потребуется 2 х 10.1 = 20.2 Мбайта и т.д. 2) В этой задаче много неизвестных, а ход её решения обратный по отношению к предыдущей задаче. 2.6 Мбайта = 2.6 х 1024² = 2 726 297.6 байт. В одной минуте 60с, поэтому объем информации за одну секунду не может превышать 2 726 297.6 / 60 = 45 438.3 байт. А теперь это число нужно разделить на произведение трех значений: количества каналов записи, частоты дискретизации в герцах и разрешения (количества байт, отводимых для хранения одного отсчета). Все эти значения нам неизвестны, поэтому у задачи нет однозначного решения. Например, если канал один, а разрешение равно 1 байту, то частота дискретизации не может превышать 45 438 байт, что примерно соответствует общепринятой частоте 44 100 Гц (44.1 кГц).
banketvoshod
04.09.2022
1) Частота дискретизации 44.1 кГц означает, что в секунду делается 44 100 отсчетов. Разрешение 16 бит (т.е. 16/8=2 байта) требует для хранения каждого отсчета 2 байта, а для хранения информации за 1 секунду - 2 х 44 100 = 88 200 байт. Две минуты - это 2 х 60 = 120 секунд и тогда общий объём составит 88 200 х 120 = 10 584 000 байт или 10 584 000 / 1024 = 10 335.94 Кбайт, или 10 335.94 / 1024 = 10.1 Мбайт И все это - для одного канала записи (монофонической). Если запись стереофоническая - то каналов два и потребуется 2 х 10.1 = 20.2 Мбайта и т.д. 2) В этой задаче много неизвестных, а ход её решения обратный по отношению к предыдущей задаче. 2.6 Мбайта = 2.6 х 1024² = 2 726 297.6 байт. В одной минуте 60с, поэтому объем информации за одну секунду не может превышать 2 726 297.6 / 60 = 45 438.3 байт. А теперь это число нужно разделить на произведение трех значений: количества каналов записи, частоты дискретизации в герцах и разрешения (количества байт, отводимых для хранения одного отсчета). Все эти значения нам неизвестны, поэтому у задачи нет однозначного решения. Например, если канал один, а разрешение равно 1 байту, то частота дискретизации не может превышать 45 438 байт, что примерно соответствует общепринятой частоте 44 100 Гц (44.1 кГц).
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, вычисляющую сумму всех нечетных чисел от 1 до н, использовать цикл с постусловием
n, i, s: integer;
begin
s := 0;
i := 0;
read(n);
repeat i := i + 1;
if(i mod 2 <> 0) then s := s + i;
until i = n;
write(s);
end.