Bezzubova_Stepanov1355
?>

Решить по информатике(паскаль): составить программу для решения следующей : даны целые числа k и n (вводятся с клавиатурывывести 2n+1 раз число k в столбик.

Информатика

Ответы

Дементьева-Артем1315
// PascalABC.NET 3.2, сборка 1439 от 09.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var k:=ReadInteger('K=');
  var n:=ReadInteger('N=');
  for var i:=1 to 2*n+1 do Writeln(k)
end.

Пример
K= 666
N= 5
666
666
666
666
666
666
666
666
666
666
666
Бернард pokerman
1) V=x*y*G
G - глубина изображения 
C - количество цветов
c=2^G => g=6
V=(2^7 * 2^8 * 6)/2^13 = 24
ответ 24
(2^13 т.к. в килобайтах)

2) V=(2^7 * 2^7 * 5)/2^13=10
ответ: 10

3) V=(2^6 * 2^7*7)/2^13=7 
ответ: 7

4) V=(2^6 * 2^8 * 8)/2^13=16
ответ: 16

5) V=(2^5 * 2^10 * 7)/2^13=28
ответ: 28

6) V=(2^9 * 2^10 * 6)/2^13=384
ответ: 384

7) V=(2^9 * 2^8 * 5)/2^13=80
ответ: 80

8) V=(2^7*2^9*4)/2^13=32
ответ: 32

9) V=(2^7 * 2^8 * 3)/2^13=12
ответ: 12

10) V=(2^7 * 2^7 * 8)/2^13=16
ответ: 16

11) V=x*y*G; G=V/(x*y)
V=24*2^13
x*y=2^7*2^8 => G=(24*2^13)/(2^15)=8
т.к. c=2^G => c=2^8=256 цветов.
ответ: 256

12) G=(10*2^13)/(2^14)=5
c=2^5=32 цвета 
ответ: 32

13) G=(7*2^13)/(2^13)=7
c=2^7=128 цветов
ответ: 128

14) G=(16*2^13)/(2^14)=8
c=2^8=256 цветов
ответ: 256

15) G=(28*2^13)/(2^15)=7
c=2^7=128
ответ: 128
aivia29
Var n:integer;
a:array[1..27] of string[15]=
 ('один','два','три','четыре','пять','шесть','семь','восемь','девять',
  'десять','одиннадцать','двенадцать','тринадцать','четырнадцать',
  'пятнадцать','шестнадцать','семнадцать','восемнадцать','девятнадцать', 
  'двадцать','тридцать','сорок','пятьдесят','шестьдесят','семьдесят',
  'восемьдесят','девяносто');
begin
write('N (1..99) = ');
readln(N);
if (n>=1)and(n<=19)
  then writeln(a[n])
  else begin 
       write(a[n div 10 + 18]);
       if n mod 10 <> 0 then write(' ',a[n mod 10]);
       writeln;
       end;
end. 

Пример:
N (1..99) = 46
сорок шесть

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить по информатике(паскаль): составить программу для решения следующей : даны целые числа k и n (вводятся с клавиатурывывести 2n+1 раз число k в столбик.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

fafina12586
Fedorov1283
hacker-xx1
BrezhnevaKoidula
Usynin-nikolay
Umkatoys50
Dimston134877
Нана_Елена
Fedorovna
koptevan6
Ofelya1308
Shitikov-M.A.1307
tatry2005
yanermarina87
evgeniy1988486
▲