kolgatin69
?>

Составьте программу с for, которая будет вычислять сумму первых , чёрных n чисел. if i mod 2=0

Информатика

Ответы

cimora-kativ
Программа на скрине! Надеюсь
Составьте программу с for, которая будет вычислять сумму первых , чёрных n чисел. if i mod 2=0
kristi-a-90

Program Zn;

uses CRT;

type mas=array [1..20, 1..20] of real;

var A:mas; i,j,g,b,n,m,o:integer;   l:real;

Begin

     clrscr;

     write ('Введите диапазон массива: ');

     readln (g,b);

     write ('Введите размер массива: ');

     readln (n,m);

     Randomize;

     For i:=1 to n do

         Begin

          For j:=1 to m do

             Begin

                  A[i,j]:=random(b-g)+g;

                  write (A[i,j]:5:0, '  ');

             End;

             writeln;

         End;

     O:=0;

     For i:=1 to n do

       Begin

         For j:=1 to m do

             Begin

                  A[3,j]:=O;

             End;

       End;

     For i:=1 to n do

         Begin

           For j:=1 to m do

              If i=1 then

               Begin

                    L:=l+A[i,j];

               End;

         End;

     writeln ('Новый массив');

     For i:=1 to n do

        Begin

         For j:=1 to m do

             Begin

                  write (A[i,j]:5:0, '  ');

             End;

             writeln

        End;

        writeln ('Сумма элементов первой строки= ',l:5:0);

readln;

End.

 Вообщем вот.

 

mariapronina720126
Программа поиска элемента в произвольном массиве:
const n=10;
var a:array[1..n+1] of integer;
p,i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 a[i]:=random(21);
 write(a[i]:4);
 end;
writeln;
write('p = '); readln(p);
a[n+1]:=p;
i:=1;
while a[i]<>p do i:=i+1;
if i<=n
 then writeln('Искомый элемент найден, его номер = ',i)
 else writeln('Искомый элемент не найден');
end.

Пример 1:
Исходный массив:
   7  17  16  13   0   1  19  20  12   5
p = 13
Искомый элемент найден, его номер = 4

Пример 2:
Исходный массив:
  20   4   5  12  14  10  11  16  18  20
p = 15
Искомый элемент не найден

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу с for, которая будет вычислять сумму первых , чёрных n чисел. if i mod 2=0
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

morozov1605
ruslan
Серопян
Вадим-Рашад323
Валиахметова
korotinadasha07
Aleksandrovich1075
extremhunter
Эдуардович873
tolyan791
pwd10123869
vvk2008
nsoro937
shumilovs7252
Seropyan-Elena1944