MariyaKhanbalaeva585
?>

Составить программу для нахождения суммы трёх переменных. - паскаль. быстро; ) заранее.

Информатика

Ответы

Евгений
var
a,b,c:integer;

begin 
write('a: '); 
readln(a);
write('b: ');
readln(b);
write('c: ');
readln(c);
writeln('sum = ',a+b+c);
end.
dream2366
Цифрами обозначены строки необходимые в соответсвующей программе, остальные - общие. Ну и переменные смотри

var   
a : array [1..200] of longint;   
p,max : integer;   
n,i,j : integer; 
begin 
readln (n); 
p := 1;     // 1 
max := 0;   // 2 3   
for i := 1 to n do   
begin     
readln (a[i]);      
p := p * a[i];  // 1     
if a[i] > max then //2 3       
begin                 //2 3
max := a[i]; // 2 3       
j := i; //3       
end;       // 2 3
end;     
writeln (p); //1   
writeln (max); //2   
writeln (j); //3 
end.
Демидова Красноцветов
1) В цикле Repeat Until идет проверка, что число введено в диапазоне [0..200}
var
i,n:integer;
a:longint;
p:real;
begin
p:=1;
Repeat
    readln(n);
Until (n>=0)and(n<=200);
for i:=1 to n do
   begin
        readln(a);
        p:=p*a;
   end;
writeln(p);
end.

2)
var
i,n:integer;
a,max:longint;
begin
Repeat
    readln(n);
Until (n>=0)and(n<=200);
for i:=1 to n do
   begin
        readln(a);
            if a>max then
                max:=a;
   end;
writeln(max);
end.
3)
var
i,n:integer;
a,min:longint;
begin
Repeat
    readln(n);
Until (n>=0)and(n<=200);
for i:=1 to n do
   begin
        readln(a);
            if a<min then
                min:=a;
   end;
writeln(min);
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для нахождения суммы трёх переменных. - паскаль. быстро; ) заранее.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Vika-simonenko
zrv85
Apresov
printlublino
lorsam36
nevasoundmsk36
fancy-decor67
ИП_Рамис873
intermar2000
Zaikinarusina
moidela87
гайсанов
xachen
irina25095462
Makarov
▲