kristina
?>

Написать программу , которая вычисляет расстояние между точками a(x₁, y₁) и b(x₂, y₂) с точностью до 0, 1 по формуле ab=√(x₂-x₁)²+(y₂-y₁)². язык программирования pascal. p.s. (x₂-x₁)²+(y₂-y₁)² полностью под корнем

Информатика

Ответы

AndreevManaeva
Var
   Ax,Ay,Bx,By:real;
Begin
WriteLn('Точка A:');
Write('   x: ');ReadLn(Ax);
Write('   y: ');ReadLn(Ay);
WriteLn('Точка B:');
Write('   x: ');ReadLn(Bx);
Write('   y: ');ReadLn(By);
WriteLn('|AB| = ',Sqrt(Sqr(Bx-Ax)+Sqr(By-Ay)):0:1);
End.
ЮлияНиколаевна1748

a=8

Объяснение:

идём по шагам:

1 Шаг    a=5  b=7

2 Шаг  проверяем b<10 или нет.  Да меньше. Идём по стрелке ДА

3 Шаг  проверяем a<= b  у нас это 5<=7  Да меньше. Идём по стрелке ДА

4 Шаг  увеличиваем а и b на единицу, становится a=5+1=6  b=7+1=8  возвращаемся по стрелке к шагу 2

5 Шаг  проверяем 8<10 или нет.  Да меньше. Идём по стрелке ДА

6 Шаг  проверяем 6<=8  Да меньше. Идём по стрелке ДА

7 Шаг  увеличиваем а и b на единицу, становится a=6+1=7  b=8+1=9  возвращаемся по стрелке к шагу 2

8 Шаг  проверяем 9<10 или нет.  Да меньше. Идём по стрелке ДА

9 Шаг  проверяем 7<=9  Да меньше. Идём по стрелке ДА

10 Шаг  увеличиваем а и b на единицу, становится a=7+1=8  b=9+1=10  возвращаемся по стрелке к шагу 2

11 Шаг проверяем 10<10 или нет.  Нет.  Идём по стрелке Нет. Выход из алгоритма. На этом этапе a=8

kolefe22171

При попытке воспроизведения файла мультимедиа с проигрывателя Microsoft Windows Media появляется следующее сообщение об ошибке:

Не удается воспроизвести файл. Формат не поддерживается (ошибка=80040265)

Причина

Такое поведение возможно в следующих случаях.

Один или несколько файлов проигрывателя Windows Media отсутствуют или повреждены.

Вы пытаетесь воспроизвести файл мультимедиа, формат которого не поддерживается проигрывателем Windows Media. Например, вы пытаетесь воспроизвести VIV-файл. Проигрыватель Windows Media не поддерживает такие файлы.

Файл мультимедиа поврежден.

Не установлен кодек, необходимый для обработки файла мультимедиа.

Проигрыватель Windows Media не поддерживает кодек, необходимый для обработки файла мультимедиа.

Решение

Чтобы решить проблему, выполните описанные ниже действия. После выполнения каждого действия проверьте, устранена ли проблема.

Примечание. Проигрыватель Windows Media поддерживает наиболее распространенные форматы файлов мультимедиа. Однако он не поддерживает все доступные форматы. В шаге 1 проверьте, что проигрыватель Windows Media поддерживает формат файла, который вы пытаетесь воспроизвести. Если проигрыватель Windows Media не поддерживает его, не выполняйте дальнейшие действия. Вместо этого свяжитесь с распространителем файла и узнайте о наличии подходящего проигрывателя.

Примечание. Приведенные ниже действия могут отличаться в зависимости от версии установленной на компьютере операционной системы Microsoft Windows. В этом случае для выполнения этих действий см. документацию к продукту.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу , которая вычисляет расстояние между точками a(x₁, y₁) и b(x₂, y₂) с точностью до 0, 1 по формуле ab=√(x₂-x₁)²+(y₂-y₁)². язык программирования pascal. p.s. (x₂-x₁)²+(y₂-y₁)² полностью под корнем
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

КОРМИЛИЦЫНА
Nikolaevna Malika1511
angelinaugan119
Karmelita1978
Акоповна
milenaochirova01017424
svetavancevich
Fedorovich_Aleksandrovich685
Денис_Петровна
Galliardt Sergeevna1284
Elenazhukovafashion7
nadjasokolova2017
armusaeff
leonid-adv70
Orestov563