Коваленко
?>

На вход программы поступает последовательность из n неотрицательных целых чисел, каждое из которых не больше 1000. требуется определить, какая сумма цифр чаще всего встречается среди этих чисел. если таких значений несколько, необходимо вывести наибольшее из них. входные данные: на вход программе подаётся натуральное число n (n< = 1000), а затем n натуральных чисел, каждое из которых не превышает 1000. пример входных данных: 3 13 22 32 выходные данные: программа должна вывести наибольшую сумму цифр, которая чаще всего встречается среди введённых чисел. пример выходных данных для примера входных данных: 4 два числа имеют сумму цифр 4. паскаль abc

Информатика

Ответы

marinakovyakhova
Егэ:)

var N, x, sum, maxi, i:integer;
a:array [0..27] of integer;
begin
readln(N);
sum:=0;
for i:=1 to N do beginreadln(x);
while x>0 do beginsum:=sum+x mod 10;x:=x div 10;end;a[sum]:=a[sum]+1;sum:=0;end;
for i:=0 to 27 doif a[i]>maxi then maxi:=i;
writeln(maxi);end.
На вход программы поступает последовательность из n неотрицательных целых чисел, каждое из которых н
Golovinskii_Sirotkina1944
Program project1777;
uses  math,  Classes ;
 var   x,y,z:integer; 
 begin     
  writeln('vedite 1 chislo');readln(x);   
  writeln('vedite 2 chislo');readln(y); 
   writeln('vedite 3 chislo');readln(z); 
   begin
     if ((x>y) and (x>z)) then     writeln('samoe bolshoe chislo ',x) 
   else   
  if ((y>x) and (y>z)) then     writeln('samoe bolshoe chislo ',y)   
 else 
   if ((z>x) and (z>y)) then  
 writeln('samoe bolshoe chislo ',z); 
    end;     
begin   
  if ((x<y) and (x<z)) then 
   writeln('samoe malenkoe chislo ',x)
     else 
   if ((y<x) and (y<z)) then   
 writeln('samoe malenkoe chislo ',y) 
   else   
 if ((z<x) and (z<y)) then 
   writeln('samoe malenkoe chislo ',z);
     end;
   readln;
   end.
Umkatoys50
Формально к русскоя языке 33 буквы, считая что в вернем и нижнем регистре они разные, то получаем мощность алфавита + цифры 33*2+10=76
к этому идут знаки припинания ,.?!:; (7 включая пробел) ()+-*/= (7 арифм. действий со скобками) итого 90
а теперь начинается куча разночтений, считать ли закрывающие и открывающие кавычки разными? а одинарные с двойными? переносы строк и табуляции? если все брать по максимуму, включая разные _\| и т.д. то получаем еще 30 разных спецсимволов без учета математических дельт, сигм и прочих сумматоров
т.о. общяя мощность может считаться равной ~ 120

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

На вход программы поступает последовательность из n неотрицательных целых чисел, каждое из которых не больше 1000. требуется определить, какая сумма цифр чаще всего встречается среди этих чисел. если таких значений несколько, необходимо вывести наибольшее из них. входные данные: на вход программе подаётся натуральное число n (n< = 1000), а затем n натуральных чисел, каждое из которых не превышает 1000. пример входных данных: 3 13 22 32 выходные данные: программа должна вывести наибольшую сумму цифр, которая чаще всего встречается среди введённых чисел. пример выходных данных для примера входных данных: 4 два числа имеют сумму цифр 4. паскаль abc
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

moonligh3560
milo4ka26
Khlistova1488
annodomini1
shutovaa3471
НосовЖелиховская
irinatikhonov
Serezhkin
Narine natalya
NarekAlekseevich779
gresovanatalya
rynaodal
Shpunt-86
myudanova631
imiryakubov
▲