evoque2014
?>

1. составьте программу в gpaph abc. организовать имитацию движения шарика по экрану монитора. 2. составьте программу в pascal abc. с начала суток секунд (n – целое найти количество полных минут с начала суток. 3. составьте программу в gpaph abc. нарисовать светофор с надписями.

Информатика

Ответы

kosharikclub
1)
uses graphabc;
begin
  window.IsFixedSize := true;
  brush.Color := clred;
  lockdrawing;
  for var i := 50 to 590 do
  begin
    circle(i, 220, 50);
    redraw;
    window.Clear;
  end;
  window.Close;
end.
2)
var
  n: integer;
 
begin
  read(n);
  write(n div 60);
end.
3)В приложении.
glebshramko
Для того, чтобы перевести целое число из десятичной в двоичную систему счисления, необходимо разделить его на два, а затем делить на два каждое полученное частное до тех пор, пока не получится единица. Искомое двоичное число записывается как последовательность цифр, равных последнему частному (единице) и всем полученным остаткам, начиная с последнего.

Надо перевести сначала 21 в двоичную, потом 2 в двоичную и потом 2002 в двоичную

Получается вот так:
21 = 10101
2=10
2002 = 11111010010

В итоге:
10101.10.11111010010
Aleksandrovich1669

Режимы открытия файлов Python:

Режим Обозначение

'r' открытие на чтение (является значением по умолчанию).

'w' открытие на запись, содержимое файла удаляется, если файла не существует, создается новый.

'x' открытие на запись, если файла не существует, иначе исключение.

'a' открытие на дозапись, информация добавляется в конец файла.

'b' открытие в двоичном режиме.

't' открытие в текстовом режиме (является значением по умолчанию).

'+' открытие на чтение и запись

Синтаксис:

>>> f = open('text.txt')

>>> f.read(1)

'H'

>>> f.read()

'ello world!\nThe end.\n\n'

>>> f = open('text.txt')

>>> for line in f:

...     line

...

'Hello world!\n'

'\n'

'The end.\n'

'\n'

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. составьте программу в gpaph abc. организовать имитацию движения шарика по экрану монитора. 2. составьте программу в pascal abc. с начала суток секунд (n – целое найти количество полных минут с начала суток. 3. составьте программу в gpaph abc. нарисовать светофор с надписями.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

iservice38
татьяна1245
Aleksandrovich-Mayatskikh
Ионов202
Yurevich-Vladimirovich
Borisovna24
valueva260860
zotovinbox468
kulinarprotv
YekaterinaAbinskov
MAXIM76748
fullhouse9991
oksana77768
tsigankova2018
kenni19868