sbelova
?>

Составьте программу на паскале. составить ведомость, включающую сведения об аудитории: номер аудитории, этаж, предназначение аудитории (лекции, лабораторные занятия дополнить список ещё одной аудитории.

Информатика

Ответы

Шиловский126
// PascalABC.NET 3.2, сборка 1449 от 23.05.2017
// Внимание! Если программа не работает, обновите версию!

type
  Предназначение=(лекции,лабораторные);
  Ведомость=record
    аудитория:integer;
    этаж:integer;
    назначение:Предназначение;
  public
    constructor Create(pa,pe:integer;pn:Предназначение);
    begin
      аудитория:=pa;
      этаж:=pe;
      назначение:=pn
    end;
  end;

begin
  var Вед:=new List<Ведомость>;
  Вед+=new Ведомость(132,1,лекции);
  Вед+=new Ведомость(204,2,лабораторные);
  Вед.Println(NewLine)
end.

Результат
(132,1,лекции)
(204,2,лабораторные)
vasavto1

Объяснение:

Чтобы предотвратить возможные конфликты несовместимости разрешений при принудительной установке пользовательского режима, поставьте флажок на нижнем пункте настроек масштабирования.

В левом меню найдите вкладку под названием «Настройки масштабирования» и переместите ползунок на панели «Сжатая развертка – Растянутая развертка» так, чтобы изображение заполнило экран целиком. Кроме того, убедитесь, что изображение отображается строго точно по центру. В противном случае некоторые его части могут быть усечены.

Ka-shop2791
PascalABC.NET 3.3.5, сборка 1662 от 29.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var n:=ReadInteger('n=');
  WriteAllText('MyFile.txt',SeqRandom(n,-99,99).JoinIntoString);
  var (mn,mx):=(MaxInt,-MaxInt);
  foreach var line in ReadLines('MyFile.txt') do begin
    var a:=line.ToIntegers;
    (mn,mx):=(Min(a.Min,mn),Max(a.Max,mx))
    end;
  Writeln('Cумма min+max = ',mn,'+',mx,' = ',mn+mx);
  ReadAllText('MyFile.txt').Println // контрольный вывод файла
end.

Пример
n= 20
Cумма min+max = -99+71 = -28
62 -72 39 -93 -99 -46 -77 71 -12 13 -89 18 -17 19 -35 -62 30 17 -74 37

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу на паскале. составить ведомость, включающую сведения об аудитории: номер аудитории, этаж, предназначение аудитории (лекции, лабораторные занятия дополнить список ещё одной аудитории.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Васильевич Валерьевна
retropluse832
rubanvladimir374
Serdechnaya636
videofanovitch
cherkashenko87543
Шаленко
Климова1317
Геннадьевна_Петр
alfaantonk
Aleksei368
katekn6032
maryshecka
hrviko
elenakarpova709