mar1030
?>

Составить программу формирования массива а из n случайных вещественных чисел, сделать возможным его редактирование. вычислить сумму дробных частей положительных элементов массива.

Информатика

Ответы

Artur-62838
{$APPTYPE CONSOLE}
Const
   N = 13;
Var
   A:array[1..N] of real;
   i,C:integer;
Procedure ZAPOLNENIERND();
Var i,j:integer;
Begin
Randomize;
For i:= 1 to N do
    A[i]:=random*21-10;
End;

Procedure BbIBOD();
Var i,j:integer;
Begin
For i:= 1 to n do
    Write(A[i]:4:1,' ');
WriteLn;
End;

Procedure RE();
Begin
Write('i = ');ReadLn(i);
Write('A[',i,'] = ');ReadLn(A[i]);
End;

Procedure SF();
Var
   i:integer;
   S:real;
Begin
S:=0;
For i:= 1 to n do
    if A[i] > 0 then S:=S+Frac(A[i]);
WriteLn('S = ',S);
End;

Begin
ZAPOLNENIERND();
BbIBOD();
Repeat
WriteLn;
WriteLn('1 - заполнить массив случайными числами');
WriteLn('2 - ввести новое значение заданного элемента');
WriteLn('3 - вычислить сумму дробных частей положительных элементов массива. ');
WriteLn('4 - вывод массива');
WriteLn('9 - выход');
ReadLn(C);
Case C of
1:
  Begin
  ZAPOLNENIERND;
  BbIBOD;
  End;
2:RE;
3:
  Begin
  SF();
  End;
4:BbIBOD;
End
Until C = 9;
End.
qelmar461
Виртуальное общения - знакомая ситуация для нашего времени. Люди знакомится в социальных сетях, общаются, иногда встречаются реальной жизни.
Это может быть полезным - пообщаться с человеком, который тебя не знает, услышать его непредвзятое мнение. Сеть дает расслабиться.
Ты можешь быть кем угодно, с какой угодно внешностью и характером.
Это дает свободу мошенникам и разнообразным шутникам, которым нечего делать, кроме как издеваться над людьми. В этом заключается вред виртуального общения - ты не знаешь с кем переписываешься.
Я не против такого общения, но нужно быть осторожным.
alfakurs

На мой взгляд, самая интересная, но сложная профессия - это быть врачом.

Врач - очень благородная профессия. В современном мире очень быстро развивается медицина. Ведь человек, его здоровье - это самое важное, что есть на земле. Врачи бывают разных

специальностей. Например, лор, невролог, врачи скорой Я думаю, что врачам скорой

сложнее всего. Представьте, сколько вызовов за день могут взвалить на свои плечи эти трудолюбивые люди. Мы должны с уважением относиться к врачам. Ведь придет и наш черед

обратиться к ним за И они Врачи никогда не кинут тебя в беде.

Вот почему я считаю, что врач - это самая благородная и трудная профессия на земле.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу формирования массива а из n случайных вещественных чисел, сделать возможным его редактирование. вычислить сумму дробных частей положительных элементов массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

SitnikovYurii5
Терентьева
picassovrn
Igorevich1512
sov0606332
manager9
Moroshkina-Aristova2011
vallod
Rik200081490
Smolkovaya
Павел
shmanm26
colus77
yuraotradnov
arbekova