Витальевна
?>

Abc.net паскаль. строки, обработка строк "дан произвольный текст на языке. написать программу, которая, выводит слова с нечетной длиной и заканчивающиеся на «ая»"

Информатика

Ответы

Yeroshkina411
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  ReadlnString('Вводите:').ToWords.Where(w->(w.Length).IsOdd)
    .Where(w->w.Right(2)='ая').Println
end.
alexander4590
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var (p,q,s):=(1,2,0);
  var k:=0;
  Write('(1,5) ');
  for var i:=3 to 1000 do begin
    var (flag,j,r):=(True,2,Round(Sqrt(i)));
    while flag and (j<=r) do
      if i mod j = 0 then flag:=false
      else j+=1;
    if flag then begin
      (p,q,s):=(q,s,i);
      if q-p=4 then Write('(',p,',',q,') ')
      else
        if s-p=4 then Write('(',p,',',s,') ')
      end
    end
end.

Результат
(1,5) (3,7) (7,11) (13,17) (19,23) (37,41) (43,47) (67,71) (79,83) (97,101) (103,107) (109,113) (127,131) (163,167) (193,197) (223,227) (229,233) (277,281) (307,311) (313,317) (349,353) (379,383) (397,401) (439,443) (457,461) (463,467) (487,491) (499,503) (613,617) (643,647) (673,677) (739,743) (757,761) (769,773) (823,827) (853,857) (859,863) (877,881) (883,887) (907,911) (937,941) (967,971)
Korobeinikov-Yulich23

•Находиться в классе в  верхней или во

влажной одежде;

     •Класть одежду и сумки на столы;

     •Находиться в классе с напитками и едой;

     •Располагаться сбоку или сзади от

включенного монитора;

     •Присоединять или отсоединять кабели,

трогать разъемы, провода и розетки;

     •Передвигать компьютеры и мониторы;

     •Прикасаться  к экрану монитора;

     •Включать и выключать компьютеры

самостоятельно;

     •Перекрывать вентиляционные отверстия

на системном блоке и мониторе;

     •Вставать без разрешения преподавателя

со своих мест, когда входят посетители;

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Abc.net паскаль. строки, обработка строк "дан произвольный текст на языке. написать программу, которая, выводит слова с нечетной длиной и заканчивающиеся на «ая»"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

md-masya
sveremeev816
tarhan1221
osnovnoisklad3551
Станиславович1830
Goldaram84
nkaminskaja
Budanov317
juliat200520
asvirskiy26
dmitrij-sp7
narkimry134
КутузоваМартенюк
mkrtchyananaida6995
inbox466