Составить программу в с++ дан массив размера n и целые числа k и l (1 < k ≤ l ≤ n найти сумму всех элементов массива, кроме элементов с номерами от k до l включительно.
#include <iostream>#include <iomanip>#include <ctime> using namespace std; int main(){ setlocale(LC_ALL, "RUSSIAN"); const int N = 10; int arr[N]; int K, L, sum = 0, sumexcl = 0; srand(time(NULL)); for (int i = 0; i < N; i++) { arr[i] = rand() % 10; sum += arr[i]; } cout << "Введите K >> "; cin >> K; cout << "Введите L >> "; cin >> L; for (int i = 0; i < N; i++) { cout << arr[i] << " "; if((i>=K) && (i<=L)) sumexcl += arr[i]; } sum -= sumexcl; cout << "Результат: " << sum << endl; system("pause");}
turaev-1098
30.08.2022
Я бы сделал так: Загоняем все 5 чисел в массив. Делаем сортировку. В итоге получаем, что в массиве в интервале massiv[0]..massiv[3] будут лежать минимальные числа. Берем их, суммируем, получаем минимально возможную сумму. Аналогично и с максимальной, только суммировать будем с massiv[1]..massiv[4].
Код будет примерно такой: int max_possible_sum(char *massiv[5]){ for (int i = 1; i <5; ++i) { int sum += massiv[i]; } return sum; }
Аналогично и для самой малой суммы: int min_possible_sum(char *massiv[5]){ for (int i = 0; i <4; ++i) { int sum += massiv[i]; } return sum; }
saryba
30.08.2022
Я бы сделал так: Загоняем все 5 чисел в массив. Делаем сортировку. В итоге получаем, что в массиве в интервале massiv[0]..massiv[3] будут лежать минимальные числа. Берем их, суммируем, получаем минимально возможную сумму. Аналогично и с максимальной, только суммировать будем с massiv[1]..massiv[4].
Код будет примерно такой: int max_possible_sum(char *massiv[5]){ for (int i = 1; i <5; ++i) { int sum += massiv[i]; } return sum; }
Аналогично и для самой малой суммы: int min_possible_sum(char *massiv[5]){ for (int i = 0; i <4; ++i) { int sum += massiv[i]; } return sum; }
using namespace std;
int main(){ setlocale(LC_ALL, "RUSSIAN"); const int N = 10; int arr[N]; int K, L, sum = 0, sumexcl = 0; srand(time(NULL)); for (int i = 0; i < N; i++) { arr[i] = rand() % 10; sum += arr[i]; } cout << "Введите K >> "; cin >> K; cout << "Введите L >> "; cin >> L; for (int i = 0; i < N; i++) { cout << arr[i] << " "; if((i>=K) && (i<=L)) sumexcl += arr[i]; } sum -= sumexcl; cout << "Результат: " << sum << endl; system("pause");}