Акоповна
?>

Написать программу в паскале. дано натуральное семизначное число р. вывести на экран цифры чила, которые делятся на а без остатка. определить кол-во цифр, удовлетворяющих этому условию.

Информатика

Ответы

vahmistrova
// PascalABC.NET 3.2, сборка 1467 от 02.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Write('Введите Р и а: ');
  var (P,a):=ReadInteger2;
  var k:=0;
  while P>0 do begin
    var d:=P mod 10;
    if d mod a=0 then begin Print(d); k+=1 end;
    P:=P div 10
    end;
  Writeln(Newline,'Искомых чисел: ',k)
end.

Пример
Введите Р и а: 7568450 5
0 5 5
Искомых чисел: 3
bezpalova2013

1)Big Data – это большие данные. Если говорить более профессиональным языком, то это набор специальных методов и инструментов, которые используются для хранения и обработки огромных объемов данных для решения конкретных задач

2) в логистике: планирование грузоперевозок и оптимизация маршрутов

ритейле: персональные предложения и оптимизация выкладки товаров

финансах: оценка платеже и повышение качества сервиса

3)

Горизонтальная масштабируемость. Поскольку данных может быть сколь угодно много – любая система, которая подразумевает обработку больших данных, должна быть расширяемой. В 2 раза вырос объём данных – в 2 раза увеличили количество железа в кластере и всё продолжило работать.

2. Отказоустойчивость. Принцип горизонтальной масштабируемости подразумевает, что машин в кластере может быть много. Например, Hadoop-кластер Yahoo имеет более 42000 машин. Это означает, что часть этих машин будет гарантированно выходить из строя. Методы работы с большими данными должны учитывать возможность таких сбоев и переживать их без каких-либо значимых последствий.

3. Локальность данных. В больших распределённых системах данные распределены по большому количеству машин. Если данные физически находятся на одном сервере, а обрабатываются на другом – расходы на передачу данных могут превысить расходы на саму обработку. Поэтому одним из важнейших принципов проектирования BigData-решений является принцип локальности данных – по возможности обрабатываем данные на той же машине, на которой их храним.

4)База данных — представленная в объективной форме совокупность самостоятельных материалов (статей, расчетов, нормативных актов, судебных решений и иных подобных материалов), систематизированных таким образом, чтобы эти материалы могли быть найдены и обработаны с электронной вычислительной машин

5)субд-(Система управления базами данных)совокупность программных и лингвистических средств общего или специального назначения, обеспечивающих управление созданием и использованием баз данных

6)Реляционная база данных — база данных, основанная на реляционной модели данных

7)Объектами реляционной модели в основном являются таблицы (отношения). Целостность данных обеспечивается внешними и первичными ключами

8)Разница между иерархической моделью данных и сетевой состоит в том, что в иерархических структурах запись-потомок должна иметь в точности одного предка, а в сетевой структуре данных у потомка может иметься любое число предков.

9) пример предметной областной Школьной библиотеки. В любой библиотеке для поиска нужной литературы используются каталоги, в которых хранятся сведения обо всех имеющихся в ней книгах. Каталоги бывают алфавитные и предметные . Каталог состоит из карточек. В карточке содержатся сведения об одной книге. Карточки создаются в двух экземплярах, один из которых хранится в алфавитном каталоге, а другой — в предметном. Оба каталога содержат одни и те же карточки, но расставлены они в разном порядке.

marinadetsad
A)
var a: string;
    i: integer;
begin
     readln(a);
     for i := 1 to length(a) do
         if (a[i] <> UpCase(a[i])) then
            write(a[i], ' ');
end.

b)
var a: string;
    i, p: integer;
    q: boolean;
begin
     readln(a);
     for p := 0 to 9 do
         for i := 1 to length(a) do
             if (a[i] = inttostr(p)) then
                    q := true;
     writeln(q);
end.

c)
var a: string;
    i, p, u: integer;
    o: array [0..5] of char;
begin
     readln(a);
     o[0] := '('; o[1] := ')'; o[2] := '{'; o[3] := '}'; o[4] := '['; o[5] := ']';
     for p := 0 to 5 do
         for i := 1 to length(a) do
             if (a[i] = o[p]) then
                    u := u + 1;
     writeln(u);
end.

d)
var a: string;
    i, p: integer;
    o: array [0..7] of char;
begin
     readln(a);
     o[0] := '('; o[1] := ')'; o[2] := '?'; o[3] := '!'; o[4] := '"'; o[5] := '.'; o[6] := ','; o[7] := ',';
     for i := 1 to length(a) do
         for p := 0 to 7 do
             if (a[i] = o[p]) then
                    writeln(a[i]);
end.

Ну вот:) О, мой мозг, как же тебе досталось! ~_~

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскале. дано натуральное семизначное число р. вывести на экран цифры чила, которые делятся на а без остатка. определить кол-во цифр, удовлетворяющих этому условию.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bsn1704
deputy810
kas80
Lapushkina
АнжелаВасильевич
bezpalova2013
Sergeevich-Novikov
Елена-Семенова
kostavaani
mushatolga
Манько_Панферов
agrilandrussia
Жуков219
annakorolkova79
olegmgu1