PopovViktorovna
?>

Составить программу для вычисления значений функции f(x) на отрезке [а, ь] с шагом h. результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции. f(x) = 2sin^2(квадрат)x+1;

Информатика

Ответы

Avdeeva Inga1505
Var
  a,b,h,x,y:real;
label M;
begin
  Write('Введите a,b,h :');
  Read(a,b,h);
  x:=a;
M:
  if x<=b+h/2 then begin
    y:=2*Sqr(Sin(x))+1;
    Writeln(x:12:7,y:18:7);
    x:=x+h;
    goto M
    end
end.

Пример
Введите a,b,h :-5 4 0.2
  -5.0000000         2.8390715
  -4.8000000         2.9846879
  -4.6000000         2.9748436
  -4.4000000         2.8110930
  -4.2000000         2.5192887
  -4.0000000         2.1455000
  -3.8000000         1.7487402
  -3.6000000         1.3916487
  -3.4000000         1.1306025
  -3.2000000         1.0068151
  -3.0000000         1.0398297
  -2.8000000         1.2244341
  -2.6000000         1.5314833
  -2.4000000         1.9125010
  -2.2000000         2.3073329
  -2.0000000         2.6536436
  -1.8000000         2.8967584
  -1.6000000         2.9982948
  -1.4000000         2.9422223
  -1.2000000         2.7373937
  -1.0000000         2.4161468
  -0.8000000         2.0291995
  -0.6000000         1.6376422
  -0.4000000         1.3032933
  -0.2000000         1.0789390
   0.0000000         1.0000000
   0.2000000         1.0789390
   0.4000000         1.3032933
   0.6000000         1.6376422
   0.8000000         2.0291995
   1.0000000         2.4161468
   1.2000000         2.7373937
   1.4000000         2.9422223
   1.6000000         2.9982948
   1.8000000         2.8967584
   2.0000000         2.6536436
   2.2000000         2.3073329
   2.4000000         1.9125010
   2.6000000         1.5314833
   2.8000000         1.2244341
   3.0000000         1.0398297
   3.2000000         1.0068151
   3.4000000         1.1306025
   3.6000000         1.3916487
   3.8000000         1.7487402
   4.0000000         2.1455000
I.B.Petrishchev
Uses Crt;
Var a,b,h:real;
Begin
ClrScr;
Write('a = ');ReadLn(a);
Write('b = ');ReadLn(b);
Write('h = ');ReadLn(h);
Repeat
WriteLn('F(',a,') = ',2*Sqr(Sin(a))+1);
a:=a+h;
Until a > b;
ReadKey
End.
Pautova1119

язык программирования питон

1)

import math;

r = int(input());

print(2 * math.pi * r);

print(math.pi * r ** 2);

2)

1.

import math;

a = float(input());

b = float(input());

print((math.sqrt(a) + math.sqrt(b)) / (math.sqrt(a ** 2 + b ** 2)));

2.

import math;

z = float(input());

y = float(input());

print((z * y) / (math.sqrt(z ** 3 + y ** 3)));

3.

import math;

x = float(input());

print(math.abs(x ** 2 - 2.4 * x + ((x + 1) / (x ** 2 + 2;

3) понял что надо среднее арифмитическое сделать из трех чисел, если что-то не так понял напиши.

a = float(input());

b = float(input());

c = float(input());

print((a + b + c) / 3);

4) не понял условие, перевод не понятный. Напиши если сможешь качественно перевести.

вариант Б тоже-самое что и 4 задание.

Yevgeniya Bessonov

#include <iostream>

using namespace std;


int a, b, numb;

bool init;


int main()

{

do {

 cout << "Input a b: ";

 cin >> a >> b;

 if ((a > b) || (a <= 0) || (b <= 0))

  cout << "Input error! Try again" << endl;

} while ((a > b) || (a <= 0) || (b <= 0));

 

for (int i = a; i <= b; i++) {

 init = true;

 numb = i;

 do {

  if (numb % 10 == 0)  

   init = false;

  else if ((i / (numb % 10) * (numb % 10)) != i)

   init = false;

  numb /= 10;

 } while (numb != 0);

 if (init == true)  

  cout << i << " ";

}

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу для вычисления значений функции f(x) на отрезке [а, ь] с шагом h. результат представить в виде таблицы, первый столбец которой — значения аргумента, второй — соответствующие значения функции. f(x) = 2sin^2(квадрат)x+1;
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Андрей_Станиславовна
slspam
TatiyanaBe20135263
platonovkosty
Ye.Vadim
SERGEI124
Shevtsov1818
Silaev988
зырянов_Юрьевна378
Barabanov Gerasimenko
ogonizoloto
Ladiga_Evgenii886
monolit-kolomna
vifslafes
f-d-a-14