dmitrijku
?>

Напишите программу на языке паскаль! с клавиатуры вводится три четырёх значных числа. найти сумму нечётных цифр в наименьшем числе.

Информатика

Ответы

pavpe4198
Var
  a, b, c, sum: integer;

function min(x, y: integer): integer;
begin
  if(x > y) then result := y
  else result := x;
end;
 
begin
  sum := 0;
  read(a, b, c);
  a := min(a, min(b, c));
  while a > 0 do
  begin
    if(a mod 10 mod 2 <> 0) then sum := sum + a mod 10;
    a := a div 10;
  end;
  write(sum);
end.
forosrozhkov

Объяснение:

1. Гиперссылка — часть гипертекстового документа, ссылающаяся на элемент в этом документе или на другой объект, расположенный на локальном диске или в компьютерной сети, либо на элементы этого объекта.

2. Внутренние ссылки – это ссылки на объекты в пределах одного документа.

Внешние или удаленные ссылки – это ссылки на другие Web-серверы.

Относительные или локальные ссылки – это ссылки на другие Web-страницы или службы Internet, расположенные на одном сервере со страницей, содержащей ссылки.

3. 1 Выделите текст или рисунок, который должен представлять гиперссылку.

1. Нажмите CTRL+K. Можно также щелкнуть текст или рисунок правой кнопкой мыши и в shortcut-меню щелкнуть ссылку.

2. В окне Вставка гиперссылки введите или вставьте ссылку в поле Адрес.

4. Часть текста с добавленной ссылкой по умолчанию выделяется синим цветом, как в предыдущем предложении. При наведении курсора мыши на текст со ссылкой он или меняет цвет или выделяется подчеркиванием.

Tsibrova
Решение 1.

Представим таблицу в виде: (см. Рис. 1)
Получаем уравнение
8 + b1 + 4 = 2*b1 + (b1+2) + 4
Отсюда:
b1 = 3.
Получаем (см. Рис. 2)

Далее, заметим, что сумма по горизонтали и по диагонали равна 15.
Заполняем таблицу (см. Рис. 3)

ответ: С2 = 9

Решение 2.

Заданным свойством (иметь одинаковую сумму по горизонталям, вертикалям и диагоналям) обладает единственный МАГИЧЕСКИЙ КВАДРАТ (не учитывая его повороты и отражения относительно осей).
Это магический квадрат 3х3 с магической суммой 15 (см. Рис. 4)

ответ: С2 = 9

Петя случайно удалил значения некоторых ячеек электронной таблицы. известно, что сумма чисел в каждо
Петя случайно удалил значения некоторых ячеек электронной таблицы. известно, что сумма чисел в каждо
Петя случайно удалил значения некоторых ячеек электронной таблицы. известно, что сумма чисел в каждо
Петя случайно удалил значения некоторых ячеек электронной таблицы. известно, что сумма чисел в каждо

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке паскаль! с клавиатуры вводится три четырёх значных числа. найти сумму нечётных цифр в наименьшем числе.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Arzieva Abdulmanov1438
Tselyaritskaya Yurevich
по информатике за 7 класс.​
oaved2018
Aleksei
tyrnaus
com4047797
gbelihina
Дмитрий192
rb-zakaz
deadnobody
ivnivas2008
Yurevich1344
Shitikov-M.A.1307
azarov8906
sahar81305