Поделитесь своими знаниями, ответьте на вопрос:
Запишите полный и сокращенный вид условного оператора запишите общий вид оператора выбора запишите условия на языке pascal написать программу на языке pascal в отчете указать листинг программы и блок схему если а> mах и b
...
readln(a);
...
case a of
0 : writeln ('ноль');
1 : writeln ('один');
2 : writeln ('два');
3 : writeln ('три');
4 : writeln ('четыре');
5 : writeln ('пять');
6 : writeln ('шесть');
7 : writeln ('семь');
8 : writeln ('восемь');
9 : writeln ('девять');
end;
Условный оператор IF, ELSE
В простом виде:
if (<условие>)
then
<...>
else
<...>
Если внутри блоков с условиями идут несколько операторов, то используется операторная конструкция совместно с begin ... end
if (<условие>)
then
begin
<... 1>
<... 2>
...
end
else
begin
<... 1>
<... 2>
...
end;
Если а>mах и b<min то с=(а+b)/2 в другом случае с=0
if(a > max) and (b < min) then
c:= (a+b)/2;
else
c:= 0;