ekatef45
?>

Задан массив. составить программу которая вводит с клавиатуры 10 чисел и выводит их в обратном порядке.

Информатика

Ответы

Алексей Ксения
// PascalABC.NET 3.2, сборка 1488 от 21.06.2017
// Внимание! Если программа не работает, обновите версию!

begin
  ReadSeqReal('10 чисел через пробел:',10).Reverse.Println
end.

Пример
10 чисел через пробел: 3.6 -2.17 5 12.7 0 1e-12 82 3.18e6 -263 3.14
3.14 -263 3180000 82 1E-12 0 12.7 5 -2.17 3.6
skryabinamaria
Алг массив
нач
  цел N = 30
  целтаб a[1:N]
  цел i, k, b
  лог b1, b2
 
  нц для i от 1 до N
    вывод "a[",i,"] = "
    ввод a[i]
  кц
  вывод нс
 
  b1:=да
  b2:=да
  нц для i от 1 до N-1
    если a[i]>a[i+1] то
      b1:=нет
    все
    если a[i]<a[i+1] то
      b2:=нет
    все
  кц
  если b1=да то
      вывод "Массив упорядочен по возрастанию", нс
  все
  если b2=да то
      вывод "Массив упорядочен по убыванию", нс
  все

  k:=0
  нц для i от 1 до N
    если a[i]>9 то
      k:=k+1
    все
  кц
  вывод "k = ",k, нс

  нц для i от 1 до div(N,2)
    b := a[i]
    a[i] := a[div(N,2)+i]
    a[div(N,2)+i] := b
  кц

  вывод "Измененный массив:", нс
  нц для i от 1 до N
    вывод a[i], " "
  кц
кон
info4632
Program a1; // a1 - название твоей проги, с задают название программы.
var a,b,c, s : integer; // a, b, c, s - переменные. var — ключевое слово, после этого слова объявляют переменные.
begin // begin и end — это как скобки, в которых ты решаешь выражение
readln(a);
readln(b);
readln(c);
// readln() — оператор, с которого можно отправлять данные в компьютер. Есть и такая fорма записи. read(). Отличие read от readln в том, если использует второй вариант readln(), то каретка( _) переносится на новую строку.
s := b*2-4*a*a; // присваиваем значения переменных в переменную s.
if (s > 0) then // конструкция if else позволяет проверять условия, если это равно или не равно, то делай компьютер другое...
 writeln(' Число положительное');
else if (s  <  0) then
 writeln(' Число отрицательное');
// writeln() выводит инfу на экран.
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задан массив. составить программу которая вводит с клавиатуры 10 чисел и выводит их в обратном порядке.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

arnika-ooo1
shchepinasm
os7960
Boldinova-Marianna
NarekAlekseevich779
obitelsvel8
barabanoveugeny
Stepan Rastorgueva850
medvik
bulin2001
neganovaarxi
Titeeva-Vladimirovich283
Lesya
Chausmonk4
muraveiynik
▲