lele4kass
?>

Написать программу нужно подсчитать сумму покупки 14 карандашей по 30 рублей, 10 красных ручек по 50 рублей, 9 синих ручек по 50 рублей. программа нужна на языке paskal

Информатика

Ответы

Yurevich1701
Program p1;
var k, r_k, r_s: integer;
    begin
    WriteLn('Сколько было куплено карандашей?');
    ReadLn(k);
    WriteLn('Сколько было куплено красных ручек?');
    ReadLn(r_k);
    WriteLn('Сколько было куплено синих ручек?');
    ReadLn(r_s);
    WriteLn('Общая сумма: ', k*30 + r_k*50 + r_s*50);
end.
aggeeva

Основными этапами становления и развития вычислительной техники являются:

1. Ручной - с 50-го тысячелетия до н. э .;

2. Механический - с середины XVII века;

3. Электромеханический - с девяностых годов XIX века;

4. Электронный - с сороковых годов XX века.

1. Ручной период автоматизации вычислений начался на заре человеческой цивилизации. Он базировался на использовании пальцев рук и ног. Счет с группировки и перекладывания предметов явился предшественником счета на абаке - наиболее развитом счетном приборе древности. Аналогом абака на Руси счетов, дошедших до наших дней. Использование абака предполагает выполнение вычислений по разрядам, то есть наличие некоторой позиционной системы счисления. Вычисления на них проводились путем перемещения счетных костей и камешков (Кальк) в полосковых углублениях досок из бронзы, камня, слоновой кости, цветного стекла. В своей примитивной форме абак был дощечкой (позже он принял вид доски, разделенной на колонки перегородками). На ней проводились линии, разделявшие ее на колонки, а камешки раскладывались в эти колонки по тому же позиционным принципом, по которому кладется число на наши счеты. Это нам известно от ряда греческих авторов.

Первым устройством для выполнения умножения был набор деревянных брусков, известных как палочки Непера. Они были изобретены шотландцем Джоном Непером (1550-1617рр.). На таком наборе из деревянных брусков была размещена таблица умножения. Кроме того, Джон Непер в начале XVII века ввел логарифмы, что сделало революционное воздействие на счет. Изобретенная им логарифмическая линейка - это счетный инструмент для упрощения вычислений, с которого операции над числами заменяются операциями над логарифмами этих чисел. Конструкция линейки сохранилась в основном до наших дней. Вычисления с логарифмической линейки проводятся просто, быстро, но приблизительно. И, следовательно, она не годится для точных, например финансовых расчетов. Она, несомненно, является венцом вычислительных инструментов ручного периода автоматизации.

2. Развитие механики в XVII веке стал предпосылкой создания вычислительных устройств и приборов, использующих механический вычислений.

Эскиз механического тринадцятиразрядного устройства заключает с десятью колесами был разработан еще Леонардо да Винчи (1452- 1519рр). По этим чертежам в наши дни фирма IBM в целях рекламы построила работо машину. Первая механическая счетная машина была изготовлена ​​в 1623 г.. Профессором математики Вильгельмом Шиккардом (1592-1636рр.). В ней были механизированы операции сложения и вычитания, а умножение и деление выполнялось с элементами механизации. Но машина Шиккарда вскоре сгорела во время пожара. Поэтому биография механических вычислительных устройств ведется от машины, заключает, изготовленной в 1642 Блез Паскаль (1623-1662), в дальнейшем великим математиком и физиком.

3. Электромеханический этап развития вычислительной техники является наименее продолжительным и охватывает около 60 лет - от первого табулятора Г.Холлерита к первой ЭВМ "ENIAC".

В конце XIX в. были созданы сложные механические устройства. Важнейшим из них был устройство, разработанное американцем Германом Холлеритом. Исключительность его заключалась в том, что в нем впервые была употреблена идея перфокарт и расчеты велись с электрического тока. Это сочетание делало машину настолько работо что она получила широкое применение в свое время. Например, при перечислении населения в США, проведенного в 1890, Холлерит, с своих машин смог выполнить за три года то, что вручную делалось бы в течении семи лет, причем гораздо большим числом людей.

Начало - тридцатые годы XX века - разработка рахунковоаналитичних комплексов, состоящих из четырех основных устройств: перфоратора, контрольника, сортировщика и табулятора. На базе таких комплексов создаются вычислительные центры. В это же время развиваются аналоговые машины.

4. Электронный этап, начало которого связывают с созданием в США в конце 1945 электронной вычислительной машины ENIAC американским инженером-электронщиком Дж. П. Эккерт и физиком Дж.У. Моучли.

В истории развития ЭВТ принято выделять несколько поколений, каждое из которых имеет свои отличительные признаки и уникальные характеристики. Главное отличие машин разных поколений состоит в элементной базе, логической архитектуре и программном обеспечении, кроме того, они различаются по быстродействию, оперативной памяти ввода и вывода информации.

Персональный Компьютер, компьютер, специально созданный для работы в однопользовательском режиме. Появление персонального компьютера напрямую связана с рождением микрокомпьютера.

ПК - настольный или портативный компьютер, который использует микропроцессор как единый центральный процессор, выполняющий все логические и арифметические операции. Эти компьютеры относят к вычислительным машинам четвертого и пятого поколения.

Объяснение:все

keykov35

1.       Основные этапы: подготовка материала для выбранной темы презентации.

·         Это изображения (простые и анимированные);

·         Тексты и цитаты из статей, книг, и других источников информации.

·         Видео и аудиозаписи, которые разнообразить и более наглядно раскрыть тему.

2.       Сценарий – это иными словами схема презентации.

·         Последовательность слайдов

·         Сопровождения материалов на слайде словами рассказывающего, чтобы более подробно раскрыть тему

На первом слайде обычно отображается тема, на последующих слайдах - цели, основной материал презентации. Заканчивается презентация слайдом с выводом и слайдом с благодарностью слушателям, за просмотренный материал и уделенное время.

3. После того, как набран материал для презентации и подготовлена схема – следует самому ещё просмотреть, чтобы исключить ошибки, которые могли возникнуть во время её составления (перепутались слайды, допущены ошибки в тексте, изображение на слайде перекрывает текст, плохо выбран цвет фона из-за чего не видно текст). Далее, если к презентации есть устное сопровождение – следует включить презентацию и сопровождать её устно, чтобы по времени определить примерное время всей презентации. Также это даст возможность настроить переключение слайдов по времени, когда вы будете знать, сколько должен определенный слайд держаться на экране, чтобы вы успели закончить устное сопровождение данного слайда.

4. Отличие в том, что в интерактивной презентации можно создать кнопки, при нажатии на которые может включиться воспроизведение видео или аудиозаписи, изменение изображения, чтобы наглядно показать разницу между предыдущим.

В целом, интерактивная презентация предполагает собой взаимодействие человека с презентацией, то есть какие-то изменения с разрешения человека во время её показа.

Презентация по сценарию же, идет последовательно и без вмешательства в её ход.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу нужно подсчитать сумму покупки 14 карандашей по 30 рублей, 10 красных ручек по 50 рублей, 9 синих ручек по 50 рублей. программа нужна на языке paskal
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

preida-2
anadtacia03108988
ivanovk3599
yakushkinayuliya
АннаМаргарита
igschuschkov6211
dianakryukova00
kraevaea
Евгеньевич Балиловна1398
magazin-71
Romanovna-yana
sergeykirushev
Shlapakov1911aa
baranovaas
tashovairina