Melnik Kaveshnikova1746
?>

Составить программу которая вводит с клавиатуры 2 целых, одно дробное число и выводит на экран их разность и произведение

Информатика

Ответы

Yurkov
Pascal:
var a,b: integer;
c: real;
begin
read(a,b,c);
write(a-b-c, ' ', a*b*c);
end.
melnik-738

PascalABC.NET 3.7:

###RS.AdjacentGroup.SelectMany(x → x.Len >= 3 ? x.Len + x[0] : x.Str).Pr

Пояснение:

RS - ReadString: Возвращает значение типа string, введенное с клавиатуры.

AdjacentGroup: Группирует одинаковые подряд идущие элементы, получая последовательность массивов.

SelectMany: Проецирует каждый элемент последовательности в новую последовательность и объединяет результирующие последовательности в одну последовательность.

.Len - .Length: Длина массива.

.Str - .JoinToString: Преобразует последовательность символов в строку, не используя разделитель (при последовательность другого типа данных в качестве разделителя используется пробел).

.Pr - .Print: Выводит последовательность символов на экран, не используя разделитель (при последовательность другого типа данных в качестве разделителя используется пробел).

Пример работы:


Однажды программист вася решил послать своему другу письмо. он подробно рассказал в нем, как у него
skononova01

Информáтика (фр. Informatique; англ. Computer science) — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений[1].

Информатика включает дисциплины, относящиеся к обработке информации в вычислительных машинах и вычислительных сетях: как абстрактные, вроде анализа алгоритмов, так и конкретные, например разработка языков программирования и протоколов передачи данных.

Темами исследований в информатике являются вопросы: что можно, а что нельзя реализовать в программах и базах данных (теория вычислимости и искусственный интеллект), каким образом можно решать специфические вычислительные и информационные задачи с максимальной эффективностью (теория сложности вычислений), в каком виде следует хранить и восстанавливать информацию специфического вида (структуры и базы данных), как программы и люди должны взаимодействовать друг с другом (пользовательский интерфейс и языки программирования и представление знаний) и т. п.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая вводит с клавиатуры 2 целых, одно дробное число и выводит на экран их разность и произведение
Ваше имя (никнейм)*
Email*
Комментарий*